Ask Your Question
0

source based install of orocos_kinematics_dynamic failed with vcs not setup correctly when installing ros electric from source

asked 2011-08-04 11:36:31 -0500

ajc gravatar image

updated 2014-01-28 17:10:09 -0500

ngrennan gravatar image

I ran the following:

rosinstall ~/ros-electric/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=desktop-full&overlay=no"

And got this at the very end of the output:

Installing https://kforge.ros.org/geometry/kdlclone orocos_kinematics_dynamics-0.2.1 to /home/ajc/ros-electric/ros/orocos_kinematics_dynamics
Cloning into /home/ajc/ros-electric/ros/orocos_kinematics_dynamics...
remote: Counting objects: 2292, done.
remote: Compressing objects: 100% (893/893), done.
remote: Total 2292 (delta 1502), reused 2092 (delta 1363)
Receiving objects: 100% (2292/2292), 668.20 KiB, done.
Resolving deltas: 100% (1502/1502), done.
fatal: Cannot setup tracking information; starting point is not a branch.
ERROR: Failed to install tree '/home/ajc/ros-electric/ros/orocos_kinematics_dynamics'
 vcs not setup correctly

I realize I'm installing to ~/ros-electric/ros. I tried installing to ~/ros and the same problem emerges.

I have seen http://answers.ros.org/question/1645/vcs-not-setup-correctly-while-i-install-ros-using, and have attempted the installation about 10 times, always receiving this output.

I can and have installed diamondback with no issues. (I have removed its previous installation at ~/ros (its the only directory I removed, the problem still persists) I also tried removing the ~/.ros directory.

Some information:

git version 1.7.6
rosinstall 0.5.15
Linux whales 2.6.39-ARCH #1 SMP PREEMPT Sat Jul 9 15:31:04 CEST 2011 i686 AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 AuthenticAMD GNU/Linux

Any help would be greatly appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-08-08 15:37:13 -0500

tfoote gravatar image

I suspect that this was an issue with the repository from which it was checkout out orocos_kinematics_dynamics. That's what the error means, and I've just tried the command myself now and it works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-04 11:36:31 -0500

Seen: 820 times

Last updated: Aug 08 '11