Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

installation fails at "sudo apt-get install ros-jade-desktop-full"

I do not know what to do. everytime I try to use "sudo apt-get install ros-jade-desktop-full", terminal tells me there were unfulfilled dependencies. However, I did not set any of these and I do not know how to remove them. Nevertheless, I really need to install ROS... Do you know what I can change in order to make it work? Thank you very much!

installation fails at "sudo apt-get install ros-jade-desktop-full"

I do not know what to do. everytime I try to use "sudo apt-get install ros-jade-desktop-full", terminal tells me there were unfulfilled dependencies. However, I did not set any of these and I do not know how to remove them. Nevertheless, I really need to install ROS... Do you know what I can change in order to make it work? Thank you very much!

PS: the problem appears in this step:

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

OR

sudo apt-get install libgl1-mesa-dev-lts-utopic

(as one of them did not work, I tried the other one, too. My ubuntu version is 15.04).

The error messages:

E: Paket xserver-xorg-dev-lts-utopic kann nicht gefunden werden.
E: Paket mesa-common-dev-lts-utopic kann nicht gefunden werden.
E: Paket libxatracker-dev-lts-utopic kann nicht gefunden werden.
E: Paket libopenvg1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgles2-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgles1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgl1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgbm-dev-lts-utopic kann nicht gefunden werden.
E: Paket libegl1-mesa-dev-lts-utopic kann nicht gefunden werden.

("kan nicht gefunden werden" means "cannot be found"). I do not know why this happens. I my settings for "Software and Updates" for "download from" is "main server" (changing it to German server does not change anything). Of course, I have also done each of the first steps described in the download tutorial. I am sure that I did not type in anything wrong.

installation fails at "sudo apt-get install ros-jade-desktop-full"

I do not know what to do. everytime I try to use "sudo apt-get install ros-jade-desktop-full", terminal tells me there were unfulfilled dependencies. However, I did not set any of these and I do not know how to remove them. Nevertheless, I really need to install ROS... Do you know what I can change in order to make it work? Thank you very much!

PS: the problem appears in this step:

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

OR

sudo apt-get install libgl1-mesa-dev-lts-utopic

(as one of them did not work, I tried the other one, too. My ubuntu version is 15.04).

The error messages:

E: Paket xserver-xorg-dev-lts-utopic kann nicht gefunden werden.
E: Paket mesa-common-dev-lts-utopic kann nicht gefunden werden.
E: Paket libxatracker-dev-lts-utopic kann nicht gefunden werden.
E: Paket libopenvg1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgles2-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgles1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgl1-mesa-dev-lts-utopic kann nicht gefunden werden.
E: Paket libgbm-dev-lts-utopic kann nicht gefunden werden.
E: Paket libegl1-mesa-dev-lts-utopic kann nicht gefunden werden.

("kan nicht gefunden werden" means "cannot be found"). I do not know why this happens. I my settings for "Software and Updates" for "download from" is "main server" (changing it to German server does not change anything). Of course, I have also done each of the first steps described in the download tutorial. I am sure that I did not type in anything wrong.