ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Error while successful "sudo apt-get install ros-diamondback-desktop-full"

asked 2011-08-03 13:59:37 -0500

130s gravatar image

updated 2014-01-28 17:10:09 -0500

ngrennan gravatar image

Hi all,

I got stuck while installation. See below for the detail. Any thoughts would be appreciated.

Phenom:

  • While running "sudo apt-get install ros-diamondback-desktop-full", after downloading a few hundred MB of data, it suddenly quitted and showed "E: Unable to locate package ros-diamondback-desktop-full". I did NOT touch the computer during the downloading period.

  • Output of apt-get update: https://docs.google.com/document/d/1y...

    <- For the ROS part, the result is the same on another computer that successfully installed diamondback.

  • Output of installable ROS packages on the computer. You'll see diamondback packages are missing: https://docs.google.com/document/pub?...

Tried workaround:

Other: Another computer which is on the same network has successfully installed diamondback. And after apt-get update on the same machine, apt-get still shows ros-diamondback as installable packages.

Env: Ubuntu 10.10 Maverick, Kernel Linux 2.6.35-30-generic-pae

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Your bit.ly link doesn't work--it apparently links to a Google Doc that isn't world readable. Maybe try pastebin instead.
Patrick Bouffard gravatar imagePatrick Bouffard ( 2011-08-03 16:36:13 -0500 )edit
Oops, sorry. I switch to the original long URL, and also switched to public instead of "anyone with link" on G-docs.
130s gravatar image130s ( 2011-08-04 04:40:45 -0500 )edit
I still can't follow the 2nd link.
tfoote gravatar imagetfoote ( 2011-08-04 06:14:44 -0500 )edit
Me either. Use pastebin, it's better.
Patrick Bouffard gravatar imagePatrick Bouffard ( 2011-08-04 06:26:55 -0500 )edit
@tfoote@Patrick Bouffard sorry again. I replaced with the new URL (turned out my setting on G-docs was correct though).
130s gravatar image130s ( 2011-08-04 06:27:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-08-04 13:40:30 -0500

130s gravatar image

updated 2011-08-04 13:43:23 -0500

I found a workaround by myself. From mirror sites, I chose Case Western and did the same for the rest of steps. Then I was able to see ros-diamondback* and now download is in process.

Before then, I also tried Maryland but it returned the same result with the issue above.

edit flag offensive delete link more

Comments

Yeah, we had a bug in our distro script which invalidated the entire repository on maverick. It should be restored now.
tfoote gravatar imagetfoote ( 2011-08-04 17:47:48 -0500 )edit
@tfoote thanks, I'm glad you've fixed the problem and also the mirror site did its job.
130s gravatar image130s ( 2011-08-04 17:56:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-03 13:59:37 -0500

Seen: 790 times

Last updated: Aug 04 '11