ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
3

Dependency install failure: ros-diamondback-ros-tutorials

asked 2011-05-18 09:00:43 -0500

DG gravatar image

updated 2011-05-28 05:17:43 -0500

kwc gravatar image

Hi All,

I am using Ubuntu 10.10 and try to install ROS. I followed every step found on the website, but something is wrong at the last step. Any suggestions or hints would be appreciated.The output is as follows. (The Linux kernel is 2.6.37, and before I tried to install ROS, I had installed Matlab R2010b -- not sure if this is related, just FYI)

$ sudo apt-get install ros-diamondback-desktop-full

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-diamondback-desktop-full : Depends: ros-diamondback-ros-tutorials (= 0.2.4-s1299046906~maverick) but it is not going to be installed

Depends: ros-diamondback-geometry-tutorials (= 0.1.3-s1299047065~maverick) but it is not going to be installed

Depends: ros-diamondback-slam-gmapping (= 1.2.2-s1301689879~maverick) but it is not going to be installed

Depends: ros-diamondback-ros (= 1.4.6-s1298587606~maverick) but it is not going to be installed

edit retag flag offensive close merge delete

Comments

Did you run 'sudo apt-get update' before 'sudo apt-get install...'?
Eric Perko gravatar imageEric Perko ( 2011-05-18 09:04:04 -0500 )edit
Yes, I ran it.
DG gravatar imageDG ( 2011-05-18 09:12:59 -0500 )edit
Could you update the title of your post to more specifically state your issue; something like "Dependency install failure: ros-diamondback-ros-tutorials"
Asomerville gravatar imageAsomerville ( 2011-05-18 09:26:11 -0500 )edit
Just updated. Thanks for reminding, Asomerville. First time here.
DG gravatar imageDG ( 2011-05-18 09:32:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-05-25 21:30:17 -0500

sebsch gravatar image

I got similar errors when I accidentally added the wrong package source. E.g., I added the source for Maverick even though I was running Lucid.

Double check which version of Ubuntu you are running using

cat /etc/issue

and the package source you added using

 cat /etc/apt/sources.list.d/ros-latest.list
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-05-18 09:00:43 -0500

Seen: 277 times

Last updated: May 25 '11