Ask Your Question
-1

How to use a package from cturtle in diamondback

asked 2011-02-17 18:35:44 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

I would like to know how to use a package, say image_view for cturtle in diamondback. I tried to copy and paste in the diamondback, but, too many in dependencies have to resolve.

I guess there will be an elegant way of doing it.

Thanks in advance..

-alfa-

edit retag flag offensive close merge delete

Comments

Please don't put [SOLVED] in the title. Also, don't mark every question as a community wiki, there is no reason for that.
mjcarroll gravatar imagemjcarroll ( 2011-02-21 02:25:26 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-02-18 01:55:10 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This is generally not possible. Use the Diamondback version of image_view.

  • There are often packaging and interface changes that affect compatibility between distribution subcomponents.

  • The main reason for making distributions is to release a coherent collection of stacks at a common level.

  • External interfaces maintain compatibility unless there is some important reason for changing.

edit flag offensive delete link more

Comments

I actually want to use image_view package. It is there, the executable in the /opt/ros/diamondback/stacks/image_pipeline/image_view/bin directory. In the .../image_view directory, I've already exported the package path using this command: export ROS_PACKAGE_PATH=$PWD:$ROS_PACKAGE_PATH. The problem is that when I run to invoke rosrun in the terminal, it is not auto-completing the image_view or the like, instead, it straightaway gives "rosrun image_transport"..huhu. Any ideas??
alfa_80 gravatar imagealfa_80 ( 2011-02-18 14:11:04 -0500 )edit
Try running 'rospack profile' to update your list of packages known to rospack -- that might help your auto-completion issues.
fergs gravatar imagefergs ( 2011-02-18 15:55:12 -0500 )edit
Unfortunately, it didn't work running 'rospack profile'.
alfa_80 gravatar imagealfa_80 ( 2011-02-18 18:07:39 -0500 )edit
Please post `echo $ROS_PACKAGE_PATH` output, and `echo $ROS_ROOT`.
joq gravatar imagejoq ( 2011-02-20 12:31:46 -0500 )edit
Running"echo $ROS_PACKAGE_PATH" gives "/home/shah/ni/ni:/opt/ros/unstable/stacks" and running "echo $ROS_ROOT" gives "/opt/ros/unstable/ros". How do I change to diamondback because I do not want to use unstable.
alfa_80 gravatar imagealfa_80 ( 2011-02-20 15:30:05 -0500 )edit
Running "roswtf" gives me "Loaded plugin tf.tfwtf No package or stack in context ================================================================================ Static checks summary: Found 1 error(s). ERROR PYTHONPATH [/opt/ros/unstable/ros/core/roslib/src:/opt/ros/diamondback/ros/core/roslib/src:] is invalid: Multiple roslib directories in PYTHONPATH (there should only be one) ================================================================================ Beginning tests of your ROS graph. These may take awhile... analyzing graph... ... done analyzing graph running graph rules... ... done running graph rules Online checks summary: No errors or warnings "
alfa_80 gravatar imagealfa_80 ( 2011-02-20 15:30:40 -0500 )edit
0

answered 2011-02-20 23:16:12 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Finally this command "source /opt/ros/diamondback/setup.bash" saved me :-) Thanks everybody ..

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-17 18:35:44 -0500

Seen: 423 times

Last updated: Feb 21 '11