ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ros-electric-desktop-full not found [closed]

asked 2012-02-04 04:59:02 -0500

StrongEnough gravatar image

updated 2014-01-28 17:11:16 -0500

ngrennan gravatar image

I am attempting to install ROS Electric on an iMX53 Quick Start board running Lucid Linux 10.04. It is an ARM Cortex A8. I am following the directions for Lucid at Everything goes well until:

"sudo apt-get install ros-electric-desktop-full"

returns: "E: Couldn't find package ros-electric-desktop-full"

Suggestions? My skill level is high and I have previously successfully installed Electric on Maverick on an x86.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ahendrix
close date 2016-02-01 12:18:54.332146


Did you update the sources list? Is it correct? Did you apt-get upgrade?
joq gravatar image joq  ( 2012-02-04 06:32:05 -0500 )edit
Yes, You say "sudo apt-get upgrade" but I did "sudo apt-get update" per the instructions. Is that the problem? I don't have enough Karma to upload a screen shot, but in the Lucid "Software Sources, Other Software" tab; the item " lucid main" is checked.
StrongEnough gravatar image StrongEnough  ( 2012-02-04 07:02:00 -0500 )edit
I searched for this problem and saw nothing. Now, on the right, I see this issue Is it possible this is a mirror issue too? I'll look around for a way to change the mirror. I'm not a Linux expert yet.
StrongEnough gravatar image StrongEnough  ( 2012-02-04 07:20:27 -0500 )edit
I meant apt-get update, not upgrade.
joq gravatar image joq  ( 2012-02-04 08:55:18 -0500 )edit
I'm not sure you can get Cortex A8 precompiled .debs. AFAIK, only i386 and amd64 are packaged right now. See also
Stefan Kohlbrecher gravatar image Stefan Kohlbrecher  ( 2012-02-04 09:41:41 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2012-02-04 11:52:50 -0500

You will have to build from source, see

edit flag offensive delete link more


Agreed. There are some debs available for ARM, but not nearly the full set that are available on x86. See for the current build status.
ahendrix gravatar image ahendrix  ( 2012-02-04 19:31:28 -0500 )edit

answered 2016-02-01 12:10:59 -0500

btaher20 gravatar image

Problem with Ubuntu 64 bits 14.04.LTS After using " sudo apt-get update && sudo apt-get install ros-electric-desktop-full or only using :sudo apt-get install ros-electric-desktop-full " I get error this. E: Unable to correct problems, you have held broken packages.

I try to solve this problem by following these below command in Terminal: sudo apt-get upgrade sudo apt-get update sudo apt-get update --fix-missing

But still I get same Error in Ubuntu 14.04.LTS system. Could any body give any helpful tips to get rid of this problem.

edit flag offensive delete link more


This is a Q&A site; not a forum. Please post this as a new question rather than as an "answer" to an old question.

ahendrix gravatar image ahendrix  ( 2016-02-01 12:18:32 -0500 )edit

answered 2012-02-23 18:00:44 -0500

trroy gravatar image

Hello - I'm not an expert, and I'm definitely running a different system, but encountered a similar problem: running Ubuntu 11.10, ran through the tutorials ( and when I ran the 'sudo apt-get install ros-electric-desktop-full' command I got the error:"E: Couldn't find package ros-electric-desktop-full". I ran 'sudo apt-get update' not once but three times. After running the update the third time in a row, it found the package. As I said, not sure it's the same problem but wanted to share in case it helps.

edit flag offensive delete link more

Question Tools


Asked: 2012-02-04 04:59:02 -0500

Seen: 1,032 times

Last updated: Feb 23 '12