Ask Your Question
1

Dependency problem on ubuntu 15.04 for ROS Jade

asked 2015-09-25 11:04:34 -0500

atabak gravatar image

I am facing a problem while following the ROS installation procedure from here. When I reach the step 1.4 and type :

sudo apt-get install ros-jade-desktop-full

I'll get this error :

sudo apt-get install ros-jade-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-jade-desktop-full : Depends: ros-jade-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The purple part in the tutorial is supposed to help with dependency issues but it is not related to 15.04 and they didn't help me anyway. Needless to say, it is also not possible to only install ros-jade-simulators or ros-jade-desktop-base

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-09-27 02:36:10 -0500

130s gravatar image

From the error I assume you've already installed Gazebo, of which version is not supported in ROS Jade (that supports version 5.x).

If and only if you're NOT using other versions of Gazebo than 5.x, you can simply uninstall those versions of Gazebo, which will also uninstall related ROS packages too so that ros-jade-simulator will become installable.

If you want to use specific version of Gazebo with Indigo or Jade, Gazebo team provided an official way to install and use Gazebo5 or 6 with ROS Indigo. With this way, however, you need to specify the wrapper packages in the dependency in your package.xml.

This is not a complete answer to any possible situations, but HTH.

edit flag offensive delete link more

Comments

I am currently using Gazebo 6. Thanks for answer

atabak gravatar image atabak  ( 2015-09-27 12:21:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-09-25 11:04:34 -0500

Seen: 387 times

Last updated: Sep 27 '15