Ask Your Question
0

rosinstall behind Proxy

asked 2012-05-29 12:59:14 -0500

dinamex gravatar image

updated 2014-01-28 17:12:30 -0500

ngrennan gravatar image

Hi,

I'm currently trying to install ROS on the Pandaboard ES behind a proxy. The board runs Ubuntu 11.10 (server prebuild) and is working so far. But I'm running into failures by proceeding the installationguide for fuerte from source. http://www.ros.org/wiki/fuerte/Installation/Ubuntu/Source

I'm doing everything the same as in the tutorial but when it comes to the point of installing the second layer: rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=fuerte&variant=desktop-full&overlay=no"

I get the following failure and not a single package gets installed
Error processing 'NAME OF XY PACKAGE' : local variable 'tempdir' referenced before assignment

I set the environment as following
http_proxy=http://user:pass@proxy.xxxx.com:8080/
ftp_proxy=ftp://user:pass@proxy.xxxx.com:8080/
https_proxy=https://user:pass@proxy.xxxx.com:8080/

and everything like wget,git,apt-get is functioning but i think the proxy is still blocking the rosinstall procedure.

Would be great to get some help here. Cheers

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-06-17 07:48:41 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Rosinstall calls out to svn, git, bzr, or hg depending on what repositories you are trying to pull down. If you can make sure that those commands work, then rosinstall should start working.

If you can't get them to work using the environment, another possibility is to setup a squid transparent proxy. There are quite a few howtos if you search google


A few notes, as I recently had to deal with this:

Git Proxies

Git has it's own command line flag for proxies, and can be set by executing the following:

git config --global http.proxy http://proxyuser:proxypwd@proxy.server.com:8080

Subversion Proxies

Subversion's proxies can be set through the ~/.svn/servers file in the [global] section:

[global]
# http-proxy-exceptions = *.exception.com, www.internal-site.org
http-proxy-host = proxy.server.com
http-proxy-port = 8080
# http-proxy-username = proxyuser
# http-proxy-password = proxypwd

Wget Proxies

Wget and curl both acknowledge the http_proxy, https_proxy, and ftp_proxy that you mention above.

Mercurial Proxies

Mercurial should acknowledge the command line http_proxy, but if it doesn't, you can always set up your hgrc file.

[http_proxy] host = proxy.server.com:8080 user = proxy user passwd = proxypwd

APT Proxies

Apt should acknowledge the command line http_proxy.

With SUDO

sudo will clear out your proxy environment variables by default (meaning no proxy with any sudo'ed (sudid?) commands). To prevent this from happening, add the following to your /etc/sudoers file:

Defaults env_keep = "http_proxy https_proxy ftp_proxy"
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-29 12:59:14 -0500

Seen: 3,014 times

Last updated: Jul 02 '12