Ask Your Question
0

ROS fuerte layer 1 install fails on 64bit gentoo

asked 2012-05-10 16:58:25 -0500

Cody gravatar image

Following the directions here: http://www.ros.org/wiki/fuerte/Installation/Gentoo

After running 'sudo make install', the following is outputed:

    -- Installing: /opt/ros/fuerte/share/genlisp/stack.yaml
+ '[' -n '' ']'
+ cd /home/nyx/ros-underlay/genlisp
+ /usr/bin/env PYTHONPATH=/opt/ros/fuerte/lib/python2.7/site-packages:/home/nyx/ros-     underlay/build/gen/py: CATKpy install --prefix=/opt/ros/fuerte
running install
Checking .pth file support in /opt/ros/fuerte/lib64/python2.7/site-packages/
/usr/bin/python2.7 -E -c pass
TEST FAILED: /opt/ros/fuerte/lib64/python2.7/site-packages/ does NOT support .pth files
error: bad install directory or PYTHONPATH

You are attempting to install a package to a directory that is not
on PYTHONPATH and which Python does not read ".pth" files from.  The
installation directory you specified (via --install-dir, --prefix, or
the distutils default setting) was:

    /opt/ros/fuerte/lib64/python2.7/site-packages/

and your PYTHONPATH environment variable currently contains:

    '/opt/ros/fuerte/lib/python2.7/site-packages:/home/nyx/ros-underlay/build/gen/py:'

Here are some of your options for correcting the problem:

* You can choose a different installation directory, i.e., one that is
  on PYTHONPATH or supports .pth files

* You can add the installation directory to the PYTHONPATH environment
  variable.  (It must then also be on PYTHONPATH whenever you run
  Python and want to use the package(s) you are installing.)

* You can set up the installation directory to support ".pth" files by
  using one of the approaches described here:

  http://packages.python.org/distribute/easy_install.html#custom-installation-locations

Please make the appropriate changes for your system and try again.
CMake Error at genlisp/CMakeFiles/safe_execute_install.cmake:5 (message):
  Error executing process with arguments
Call Stack (most recent call first):
  genlisp/cmake_install.cmake:56 (INCLUDE)
  cmake_install.cmake:39 (INCLUDE)


make: *** [install] Error 1
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-05-10 17:00:58 -0500

Cody gravatar image

Note the line

/opt/ros/fuerte/lib64/python2.7/site-packages/

vs

'/opt/ros/fuerte/lib/python2.7/site-packages:/home/nyx/ros-underlay/build/gen/py:'

See the lib64 vs lib. Either something is failing to setup PYTHONPATH properly, or the install directory is wrong.

Workaround: symlink lib & lib64 together.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-10 16:58:25 -0500

Seen: 316 times

Last updated: May 10 '12