Ask Your Question
0

install desktop-full is not working

asked 2019-05-14 04:22:57 -0500

S.Yildiz gravatar image

if I try sudo apt-get install ros-kinetic-desktop-full

it says:

Reading package lists... Done
Building dependency tree       
Reading state information... Done

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-kinetic-desktop-full : Depends: ros-kinetic-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried everything to solve the broken packages problem but nothing worked.

edit retag flag offensive close merge delete

Comments

Have you at any point installed Gazebo stand-alone on this machine? A common cause for these types of errors is a dependency of ros-kinetic-simulators is already installed and is a newer version than what the ROS packages need/want. Ubuntu cannot uninstall that newer dependency and as a result it cannot install ros-kinetic-simulators for you.

gvdhoorn gravatar image gvdhoorn  ( 2019-05-14 08:22:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-16 10:50:55 -0500

jamesislost gravatar image

I can only suspect you have installed some ros packages from a more up to date version of ros, I believe this is more likely due to the dependency on ros-kinetic-simulators which was introduced in Melodic. I can only suggest you remove all presence of ros, purge and removal is pretty well documented on here, then try the reinstall following the wiki. If working on a fresh workstation I'd just suggest just reinstalling linux afresh at this point to minimise risk after backing up your files as some of these functions can be used improperly or finding later that an undesired package is causing problems.

Hopefully this helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-14 04:22:57 -0500

Seen: 291 times

Last updated: May 16 '19