Ask Your Question
0

Is ROS QT using .pro supports? or Anyone did it?

asked 2015-09-02 03:06:36 -0500

RosMinusOne gravatar image

Hello all, I am using some OpenSource project in QT creator, I want to integrate with ROS in QT, There is a qt_ros that did not use .pro of qt. In my .pro I have some important settings. That is why I have to use .pro inside qt. Is there anyone tried with qt ros with .pro ?

Thank you.

edit retag flag offensive close merge delete

Comments

afaik qt creator can read ROS' cmake files. That should be a lot easier than doing it the other way around.

dornhege gravatar image dornhege  ( 2015-09-02 03:22:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-09-02 08:49:18 -0500

allenh1 gravatar image

I'm relatively sure that .pro files are not going to work. You can, as was suggested by @dornhege, open an appropriate CMake file with Qt Creator. Here's a simple Qt project that does not use qt_ros.

You will need to open Qt Creator in a terminal (because of the profile on the system).

$ qtcreator CMakeLists.txt &

Should open the file in Qt Creator and compile appropriately.

edit flag offensive delete link more

Comments

First I generated ros package as usual and added qt project files in side src in ros package and edited CMakeLists.txt. it works fine. However, I am using qcustomplot inside my project, But when I use make command it does not compile.

RosMinusOne gravatar image RosMinusOne  ( 2015-09-07 01:09:58 -0500 )edit

You should be using catkin_make if you aren't currently... But if that's what you mean by make, you should recall that qcustomplot is not in the standard Qt library. Possibly refer to this tutorial for assistance. http://www.qcustomplot.com/index.php/...

allenh1 gravatar image allenh1  ( 2015-09-07 01:44:20 -0500 )edit

here is the full logs: http://answers.ros.org/question/21717... I used roscreate-pkg to generate ros packages. And there is Makefile for "make" But I cannot resolve my problem.

RosMinusOne gravatar image RosMinusOne  ( 2015-09-07 02:07:00 -0500 )edit

You should not be running cmake or make with ROS. Everything should be handled by catkin_make. But this is still not the issue. First, be sure you have qcustomplot on your system.

allenh1 gravatar image allenh1  ( 2015-09-07 08:06:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-02 03:06:36 -0500

Seen: 328 times

Last updated: Sep 02 '15