Ask Your Question
0

Problems with catkin_make

asked 2015-09-23 06:13:01 -0500

Morpheus gravatar image

updated 2015-09-23 08:10:39 -0500

gvdhoorn gravatar image

I am having problems with each time that I try to run catkin_make. Here is a copy of what I get:

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a configuration file for package cmake_modules.

  Set cmake_modules_DIR to the directory containing a CMake configuration
  file for cmake_modules.  The file will have one of the following names:

    cmake_modulesConfig.cmake
    cmake_modules-config.cmake

I have tried looking for the cmake_modules_DIR, but so far no luck.

Thank You!

edit retag flag offensive close merge delete

Comments

I am using hydro.

Morpheus gravatar imageMorpheus ( 2015-09-23 06:21:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-09-23 06:18:09 -0500

dornhege gravatar image
sudo apt-get install ros-hydro/indigo/jade-cmake-modules
edit flag offensive delete link more

Comments

When I run the command, I get: Unable to locate package ros-hydro/indigo.

Morpheus gravatar imageMorpheus ( 2015-09-23 06:25:06 -0500 )edit

You need to put in your ROS version only.

dornhege gravatar imagedornhege ( 2015-09-23 06:51:31 -0500 )edit
2

In your case is

sudo apt-get install ros-hydro-cmake-modules
Mago Nick gravatar imageMago Nick ( 2015-09-23 07:32:02 -0500 )edit

I still get the same CMake Error: Could not find a configuration file for package cmake_modules.

Morpheus gravatar imageMorpheus ( 2015-09-24 05:53:46 -0500 )edit

I found the problem, I had a package that was causing the problem. I removed the package, and now catkin_make works fine. Thanks to all for your help.

Morpheus gravatar imageMorpheus ( 2015-09-24 06:15:29 -0500 )edit

Hi, which package did you remove to fix the issue? I have the same problem.

filipposanfilippo gravatar imagefilipposanfilippo ( 2016-04-19 16:13:04 -0500 )edit

On kinetic, Mago Nick's comment worked for me.

sudo apt-get install ros-kinetic-cmake-modules
klindgren gravatar imageklindgren ( 2019-06-24 11:33:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-23 06:13:01 -0500

Seen: 1,934 times

Last updated: Sep 23 '15