Update Cmake for ROS

asked 2020-10-25 08:06:41 -0500

N.N.Huy gravatar image

updated 2020-10-25 15:35:36 -0500

jayess gravatar image

Hello everyone, i am trying to catkin_make a workspace relating to V-REP. However, the system required to update Cmake. I am using cmake 3.10.2 and i want to update to cmake 3.18. I have tried to update cmake according to this question link text And I checked by cmake --version and the cmake was updated to 3.18.

cmake version 3.18.4

CMake suite maintained and supported by Kitware (kitware.com/cmake)

However, when i catkin_make the workspace again, the problem was still unchanged.

CMake Error at sim_ros_interface/CMakeLists.txt:1 (cmake_minimum_required):
  CMake 3.16 or higher is required.  You are running version 3.10.2

-- Configuring incomplete, errors occurred!
See also "/home/huy/ros_vrep_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/huy/ros_vrep_ws/build/CMakeFiles/CMakeError.log".
Makefile:320: recipe for target 'cmake_check_build_system' failed
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

Can you help me to solve this problem, please! Thanks in advance !

edit retag flag offensive close merge delete


Have you tried out this solution from #q293119?

abhishek47 gravatar image abhishek47  ( 2021-03-31 01:36:14 -0500 )edit