Ask Your Question

Problems with communication between Roboguide and RVIZ

asked 2015-09-01 09:43:16 -0600

andy gravatar image

updated 2015-09-01 11:02:30 -0600

gvdhoorn gravatar image

Hello everyone.

I'm working con ROS-Industrial and with the FANUC m20ia Robot

I'm try running the ROS-Industrial programs on my FANUC simulate called RoboGuide, I follow the instructions that appear in , buy I had not success with this.

First I ran the TP program ROSTATE in AUTO mode on RoboGuide and I get the "I RSTA Waiting for ROS state prox" message on displat of Teach Pendant.

Then I run on my Linux PC (Ubuntu 14.04 LTS) the

roslaunch fanuc_m20ia_support robot_state_visualize_m20ia.launch robot_ip:= use_bswap:=false

instruction, and appear the RVIZ, but when I tried jogging the robot on RoboGuide, the model of RVIZ don't reflect the same movements. On the terminal I get:

romandy@romandy-VirtualBox:~$ roslaunch fanuc_m20ia_support robot_state_visualize_m20ia.launch robot_ip:= use_bswap:=false
... logging to /home/romandy/.ros/log/44a16120-50b6-11e5-8c2e-0800271389e3/roslaunch-romandy-VirtualBox-2831.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://romandy-VirtualBox:44066/


 * /J23_factor: 1
 * /controller_joint_names: ['joint_1', 'join...
 * /joint_state_publisher/source_list: ['my_controller/r...
 * /robot_description: <?xml version="1....
 * /robot_ip_address:
 * /rosdistro: indigo
 * /rosversion: 1.11.13

    joint_state (fanuc_driver/robot_state)
    joint_state_publisher (joint_state_publisher/joint_state_publisher)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    rviz (rviz/rviz)

auto-starting new master
process[master]: started with pid [2847]

setting /run_id to 44a16120-50b6-11e5-8c2e-0800271389e3
process[rosout-1]: started with pid [2860]
started core service [/rosout]
process[joint_state-2]: started with pid [2877]
process[joint_state_publisher-3]: started with pid [2892]
process[robot_state_publisher-4]: started with pid [2895]
process[rviz-5]: started with pid [2918]

After a time, pop out the next massage on the terminal:

ERROR 1441118076.606392345: Failed to connect to server, rc: -1. Error: 'Connection timed out' (errno: 110)
ERROR 1441118203.965873915: Failed to connect to server, rc: -1. Error: 'Connection timed out' (errno: 110)
ERROR 1441118203.966035108: Failed to receive message length
ERROR 1441118203.966095454: Failed to receive incoming message
ERROR 1441118336.189696820: Failed to connect to server, rc: -1. Error: 'Connection timed out' (errno: 110)
ERROR 1441118336.189818327: Failed to receive message length
ERROR 1441118336.189858459: Failed to receive incoming message

I did some test but I had not success. I hope someone of this community can help.

Yours sincerely, Andres

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-09-01 11:01:35 -0600

gvdhoorn gravatar image

updated 2015-09-01 11:13:10 -0600

ERROR 1441118076.606392345: Failed to connect to server, rc: -1. Error: 'Connection timed out' (errno: 110)

This seems to suggest that the fanuc_driver/robot_state node running on your ROS PC is unable to connect with the ros_state program running on your simulated robot controller. I can think of a number of reasons why this could be the case:

  1. the IP you provided for robot_ip is incorrect: make sure this is the IP of the Windows PC running Roboguide
  2. the firewall on the Windows PC does not allow external connections to Roboguide: you'll have to make sure that the frvirtual.exe process (which actually runs the virtual controller) is allowed to accept connections on ports 11000 and 11002 from hosts on your network. See Allow a program to communicate through Windows Firewall fi on how to do this for Windows 7.

You can use the following command (on your ROS pc) to check whether things would work (without having to use the robot_state_visualize_m20ia.launch file):

nc ip.of.your.windowspc 11002

This should begin to dump a continuous stream of semi-printable data to your terminal (use ctrl+c to stop it).

edit flag offensive delete link more


Uohhh!! I'm very grateful of you, some very simple but definitely I could't wiht this. Very very thanks. The problem was the robot_ip.


andy gravatar imageandy ( 2015-09-01 12:34:05 -0600 )edit

Excuse me, I have other error. Now I can see how the model of RVIZ does the same movements that the model of RoboGuide,but when close the ROS session I get a new error:

andy gravatar imageandy ( 2015-09-01 16:13:37 -0600 )edit

^C[rviz-5] killing on exit [robot_state_publisher-4] killing on exit [joint_state_publisher-3] killing on exit [joint_state-2] killing on exit ERROR 1441141619.565248423: Socket select function failed, rc: -1. Error: 'Interrupted system call' (errno: 4) [joint_state-2] escalating to SIGTERM

andy gravatar imageandy ( 2015-09-01 16:16:14 -0600 )edit

[rosout-1] killing on exit [master] killing on exit shutting down processing monitor... ... shutting down processing monitor complete done romandy@romandy-VirtualBox:~$

andy gravatar imageandy ( 2015-09-01 16:16:43 -0600 )edit

I hope you can help me, thanks

andy gravatar imageandy ( 2015-09-01 16:26:54 -0600 )edit

In general: please ask new questions in a new question. We can only give you one answer per question (it's how Askbot works).

re: new error: that is not an error. Well it is, but you can ignore it. It simply tells you that the node was shutdown right in the middle of doing something. It's ok.

gvdhoorn gravatar imagegvdhoorn ( 2015-09-02 02:17:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-09-01 09:43:16 -0600

Seen: 1,677 times

Last updated: Sep 01 '15