ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Difficulty to use Laser scanner with URG_NODE

asked 2015-06-25 09:40:51 -0500

mohsen1989m gravatar image


I am trying to get data from a hokuyo laser scanner model (UTM_30LX_EW). I have installed urg_node and all the related dependencies. To check the installation and following the urg_node page in ROS wiki, I run this code: rosrun hokuyo_node getID /dev/ttyUSB0

and I get "Error: package 'hokuyo_node' not found".

I tried to also install the hokuyo_node, but the cat_make failed. I should add my device does not show up on ttyACM0 but on the ttyUSB0. That's why I changed the code accordingly. Although, I guess that will cause some problems as well, so if you know how to make the device to be appeared as ttyACM0 instead of ttyUSB0 please let me know.

Thank you for your help

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-06-25 13:21:40 -0500

ritwik1993 gravatar image


rosrun urg_node getID /dev/ttyUSB0

If you have a look at the CMakeLists for the new package(urg_node), it should show you the new names wherever used.

The documentation for urg_node hasn't yet been updated I guess. It is almost still the same as the documentation for the older hokuyo_node package.

For the latter part of the question - I doubt that it really makes much of a difference as long as set it to the right device at initialization. You might want to have a look at this - ofcourse not on the same package anymore

edit flag offensive delete link more

answered 2015-06-26 02:46:58 -0500

mohsen1989m gravatar image

Thank you for your attention, Now I have another error:

When I run "rosrun urg_node getID /dev/ttyUSB0" I get this error:

terminate called after throwing an instance of 'std::length_error'

what(): vector::_M_fill_insert

Aborted (core dumped)

and when I try to run the urg_node by "rosrun urg_node urg_node" I get this one:

[ERROR] [1435311379.106125299]: Unknown error connecting to Hokuyo

can you please help me solve this problem?

Thank you very much for your help

edit flag offensive delete link more

Question Tools


Asked: 2015-06-25 09:40:51 -0500

Seen: 859 times

Last updated: Jun 26 '15