Ask Your Question
0

Arbotix "[Errno 11] Resource temporarily unavailable"

asked 2015-06-14 03:16:23 -0500

wjvh gravatar image

Hello all - newbie here

This weekend I've been trying to put together a turtlebot_arm live on a turtlebot using a PhantomX Pincher. I've been using the latest forks as far as I can tell - https://github.com/corb555/arbotix_ros and https://github.com/corot/turtlebot_arm - as well as some of the advice here http://answers.ros.org/question/20821...

I managed to get the system planning & executing with MoveIt and rviz with the arm floating in space, but as I was going back through the URDFs to clean up and attach the arm to the turtlebot, I've happened upon an error that's blocking comms and I can't find it anywhere online, when I run my modified turtlebot_bringup minimal.launch: "[Errno 11] Resource temporarily unavailable."

This error is shown right after the "ArbotiX connected" output of minimal.launch which would normally signal all OK to roslaunch turtlebot_arm_moveit_config and rviz.

It sounds like a hardware error but restarting/powering down the turtlebot PC and arbotix don't help, and my USB chmod 777 is fine as the Arbotix does connect before hitting the error.

Has anyone experienced this before?

Cheers

Will

edit retag flag offensive close merge delete

Comments

How are you powering the Pincher? As a test, you might try using a wall-wart to power it, just to eliminate any possible power issues. Also, it would be great if you can publish notes on this. I think you will be the first to mount the Pincher on the Turtlebot.

corb gravatar imagecorb ( 2015-06-14 19:38:40 -0500 )edit

Thanks corb. I'm using a wall wart already, still waiting for my connectors to arrive for onboard power out here in Singapore! The problem started when I moved from turtlebot_arm to the corot fork so I will revert and try to trace the problem. Once I have a working solution I'm happy to detail here

wjvh gravatar imagewjvh ( 2015-06-15 11:33:11 -0500 )edit

Deleted and remade packages - problem solved.

wjvh gravatar imagewjvh ( 2015-06-24 09:51:07 -0500 )edit

Problem remains - swapping USB ports, powering on & off and use of chmod sometimes fixes it until the next session. Could be a driver problem - will continue to investigate. Anybody else having Errno 11 problems with a PhantomX pincher & ROS Indigo?

wjvh gravatar imagewjvh ( 2015-07-11 04:16:30 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-04-16 12:02:46 -0500

wjvh gravatar image

Think I've managed to solve this - it has to do with whether the FTDI cable to the Arbotix is detected as USB0 or USB1. Once I started ensuring the Kobuki was plugged in after the FTDI, I stopped having the error.

edit flag offensive delete link more

Comments

Perhaps you can use some suitable udev rules to make this easier to manage.

gvdhoorn gravatar imagegvdhoorn ( 2016-04-16 12:21:48 -0500 )edit

Good knowledge, thanks gvdhoorn - will do. Sometimes this error also seems to present as "maximum recursion depth exceeded" for some reason. If anyone else has this issue the above also works as a fix for me.

wjvh gravatar imagewjvh ( 2016-04-18 10:26:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-06-14 03:16:23 -0500

Seen: 373 times

Last updated: Apr 16 '16