turtlebot_arm no transform from gripper_link to base_footprint

asked 2017-07-02 09:38:50 -0500

wjvh gravatar image

updated 2017-07-23 10:17:16 -0500

Hi all

After following the instructions to mount turtlebot_arm on turtlebot as per Corot's indigo-devel branch here https://github.com/corot/turtlebot_arm/ everything works fine...

...however when visualising the combined turtlebot+turtlebot_arm urdf in rviz using "roslaunch turtlebot_rviz_launchers view_robot.launch" I get an error within rviz stating "no transform from gripper_link to base_footprint"

This seems to be messing up the arm/kinect calibration. There's also an issue where one of the grippers is visualised as several meters off to the side of turtlebot in rviz. Adjusting the servo max parameters and the pincher_gripper.xacro limits doesn't seem to resolve this issue.

Has anyone else experienced this issue?

Cheers

Will

edit retag flag offensive close merge delete

Comments

Getting two errors when I run pick_and_place.py as well:

[ERROR] [1499874170.941253659]: Robot semantic description not found. Did you forget to define or remap '/robot_description_semantic'?
[FATAL] [1499874171.304092862]: Group 'turtlebot_arm' was not found.
wjvh gravatar imagewjvh ( 2017-07-12 10:46:54 -0500 )edit

Any progress on this? I cannot reproduce the problem. Which commands do you execute? Please note that you must start the turtlebot bringup to make base_footprint tf available. For the moveit demo, do you start turtlebot_arm_moveit_config/demo.launch before running ir?

jorge gravatar imagejorge ( 2017-08-22 17:26:23 -0500 )edit