Ask Your Question
0

Turtlebot arm servos not being recognized [closed]

asked 2011-11-18 07:08:37 -0600

Aroarus gravatar image

updated 2014-01-28 17:10:49 -0600

ngrennan gravatar image

I am using a turtlebot arm and just finished getting the ROS sketch uploaded to the ArbotiX board when I ran into an error. I run the command to search for the servos after having plugged only one into the board and get the following result:

turtlebot@turtlebot-laptop:~$ rosrun arbotix_python terminal.py /dev/ttyUSB0
ArbotiX Terminal --- Version 0.1
Copyright 2011 Vanadium Labs LLC
>>  ls
.... .... .... .... .... .... .... .... .... 
.... .... .... .... .... .... .... .... .... 
>>

I have tried multiple cables and multiple servos to see if either was the problem. Neither of them turned out to be the problem. I have established that the servos do at least move, since I was able to issue them commands using PyPose. The only concern that I have is the the red light on the servos first light up when I plug them in, but do not stay lit for more than a second. I am currently running the arbotix board directly off of a iRobot Create battery (as opposed to going through the power board, since the only port on my power board is being occupied by the create). I don't think that should cause a problem, but figured I would mention it. Does anyone have an idea why my computer cannot read the servos, or any recommendations for other troubleshooting steps to take? Thank you very much!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-02-29 14:15:46

1 Answer

Sort by » oldest newest most voted
0

answered 2011-11-18 15:26:24 -0600

fergs gravatar image

What firmware do you have installed on the ArbotiX? It has to be running the ros.pde sketch (the PyPose sketch won't work with that terminal).

The red lights are normal (they flash for a second when powered on).

Running directly off the 14.4V NiMH in the Create could seriously damage the servos, especially if subjected to heavy loads.

edit flag offensive delete link more

Comments

I am running the ros.pde sketch on the ArbotiX. Glad to hear about the red lights, and I am running the ArbotiX board directly off of the Create battery. the servos are plugged into the ArbotiX board for power. The only other option I have is to try and get my hands on a power board with 3 ports.
Aroarus gravatar imageAroarus ( 2011-11-18 16:24:28 -0600 )edit
Do you know how to get such a board? I haven't been able to find more than pictures online (nowhere to actually get one).
Aroarus gravatar imageAroarus ( 2011-11-18 16:24:57 -0600 )edit
I am not using Pypose in any way now, I merely mentioned it as an indicator that the servos have done something in the past.
Aroarus gravatar imageAroarus ( 2011-11-18 16:26:33 -0600 )edit

Question Tools

Stats

Asked: 2011-11-18 07:08:37 -0600

Seen: 395 times

Last updated: Nov 18 '11