Ask Your Question
1

arbotix_python arbotix servos not recognized

asked 2012-07-13 12:52:06 -0600

Scott gravatar image

Hi, I have purchased an arbotix robocontroller but the servos are not being recognized when I run arbotix_python. I am able to successfully compile and upload the ros.pde firmware without error (although I did originally get complaints about that arduino not being on option for the controller that I had to work around). So no errors of any kind, the board is being powered by an external LiPo, the servo lights up briefly when power is turned on, but again, when I run the arbotix_python, no servos are seen. Any suggestions would be appreciated as I have no errors to give me a lead on what to try next.

Output: scott@wilson:~$ rosrun arbotix_python terminal.py /dev/ttyUSB0 ArbotiX Terminal --- Version 0.1 Copyright 2011 Vanadium Labs LLC

ls .... .... .... .... .... .... .... .... .... .... .... .... .... .... .... .... .... ....

edit retag flag offensive close merge delete

Comments

Attention @fergs!

Mac gravatar imageMac ( 2012-07-13 13:14:08 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-14 13:00:13 -0600

fergs gravatar image

Have you set IDs for each of the servos? If you have multiple new servos attached, they each ship with ID 1, and none of them will be able to respond.

edit flag offensive delete link more

Comments

That is exactly what I am attempting to do, one servo at a time. The plan being to run ls, see what the servo is currently set to, and them mv it to what I need it to be. The problem is, it cannot recognize what it is set to in the first place, so I can't move it to anything.

Scott gravatar imageScott ( 2012-07-15 07:04:54 -0600 )edit

So the core of the issue is, if I am getting no compile errors on the ros.pde and it uploads just fine, then why can't I identify what the current servo ID is when I only have a single servo attached a time? I have tried it with several known good servos and same problem, so not related to the servo

Scott gravatar imageScott ( 2012-07-15 07:06:50 -0600 )edit

Hi again Fergs, I may have found a clue. I re-ran the arbotix_python node. When I first power on the board. All lights blink on as expected on the FTDI cable and the Arbotix board. But when I issue the ls command,the communication light stays on solid.

Scott gravatar imageScott ( 2012-07-15 09:18:22 -0600 )edit

Did you ever resolve this issue? I am having the same problem. Attention @Scott

Aroarus gravatar imageAroarus ( 2012-09-25 06:00:53 -0600 )edit

did you guys solve the issue, I have same problem, @fergs@Scott

Abdu gravatar imageAbdu ( 2017-09-26 09:11:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-07-13 12:52:06 -0600

Seen: 605 times

Last updated: Jul 14 '12