Ask Your Question
0

Navigation configuration problem [closed]

asked 2015-06-08 10:03:03 -0500

F.Brosseau gravatar image

updated 2015-06-09 10:00:12 -0500

Hello everybody,

EDIT: It was just a problem of parameters settings. I used the files of the reem robot to help me. https://github.com/pal-robotics

I still have one question. Shadows of obstacles and robot are considered like obstacle. I tried to modify the min_height_obstacle parameter but the "shadow point" have a too big value on the z axis. Have you any advice to fix this problem ?

Original post: I know there is already some messages about it but I really don't understand how the move_base tried to follow a given path.

I am trying to use the Navfn planner for the global planner and the dwa planner for the local planner. I put an obstacle in front of my robot (4~5 meters) and I put an objective 10 meters forward the robot. Everything seems to work fine, the obstacle is detected, the inflation is done on the costmap, the global plan avoid the occupied zone.

But the robot don't follow the path. It spin on himself or it goes in the occupied zone and get stuck.

I have tried to modify the following parameters :

  • goal_distance_bias (weight to reach the goal)
  • path_distance_bias (weight to follow a given path)
  • occdist_scale (weight to avoid obstacle) (for these parameters, if the values are high, it will be more important for the robot to respect them right ?)

Is there an error in my confiuration files or is it just a problem of parameters settings ?

Config files : base_local_planner

DWAPlannerROS:

# Current limits based on AZ3 standalone configuration.
acc_lim_x:  0.75
acc_lim_y:  0.75
acc_lim_theta: 4.00
max_vel_x:  0.500
min_vel_x:  0.212
max_rot_vel: 0.9 #0.55

prune_plan: true

xy_goal_tolerance:  0.60
yaw_goal_tolerance: 0.20

sim_time: 1 #1.7 a lorigine
sim_granularity: 0.025
vx_samples: 3
vtheta_samples: 20

occdist_scale: 0.01
goal_distance_bias: 24.0
path_distance_bias: 32.0
forward_point_distance: 0.0

oscillation_reset_dist: 0.05
meter_scoring: true

planner_frequency: 20.0
oscillation_timeout: 3.0

costmap_common_params

obstacle_range: 2.5
raytrace_range: 3.0
footprint: [[ 0.69,  0.57], [-0.69,  0.57], [-0.69, -0.57], [ 0.69, -0.57]] 
footprint_padding: 0.03
robot_radius: 0.72
inflation_radius: 0.72
transform_tolerance: 1
robot_base_frame: artemisBody
publish_frequency: 5.0

controller_patience: 2.0

NavfnROS:
    allow_unknown: true

recovery_behaviors: [
    {name: conservative_clear, type: clear_costmap_recovery/ClearCostmapRecovery},
    {name: aggressive_clear, type: clear_costmap_recovery/ClearCostmapRecovery}
]

conservative_clear:
    reset_distance: 3.00
aggressive_clear:
    reset_distance: 1.84

global_costmap_params:

global_costmap:
  global_frame: odom
  robot_base_frame: artemisBody
  update_frequency: 0.5
  publish_frequency: 0.5
  static_map: true
  width: 50
  height: 50
  origin_x: -25.0
  origin_y: -25.0

local_costmap_params:

local_costmap:
global_frame: odom
robot_base_frame: artemisBody
update_frequency: 2.0
publish_frequency: 2.0
static_map: false
rolling_window: true
width: 4.0
height: 4.0
resolution: 0.025
origin_x: -2.0
origin_y: -2.0

observation_sources: point_cloud_sensor

# assuming receiving a cloud from rtabmap_ros/obstacles_detection node
    point_cloud_sensor: {
                  sensor_frame: artemisBody,
                  data_type: PointCloud2,
                  topic: /planner/planner_cloud,
                  expected_update_rate: 0.0,
                  marking: true,
                  clearing: true,
                  min_obstacle_height: -99999.0,
                  max_obstacle_height: 99999.0}

planner part in the launch file

<group ns="planner">
    <remap from="openni_points" to="/planner/planner_cloud"/>
    <remap from="map" to="/map"/>
    <remap from="move_base_simple/goal" to="/planner/goal"/>
    <remap from="cmd_vel ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by F.Brosseau
close date 2015-06-10 02:16:52.526577

Comments

RE: latest edit: Is this closed then?

David Lu gravatar imageDavid Lu ( 2015-06-09 10:37:41 -0500 )edit

Yes I just have a few settings to make but it's working

F.Brosseau gravatar imageF.Brosseau ( 2015-06-10 02:16:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-06-09 11:49:38 -0500

dimkirt gravatar image

If you are still having a problem try changing path_distance_bias to something like 100.0, if you are ok I write it for someone with the same problem.

edit flag offensive delete link more

Comments

I changed the path distance bias and it's work better.

F.Brosseau gravatar imageF.Brosseau ( 2015-06-10 02:15:13 -0500 )edit

Question Tools

Stats

Asked: 2015-06-08 10:03:03 -0500

Seen: 534 times

Last updated: Jun 09 '15