Ask Your Question
0

Do not allow the robot to plan in unknow region for navigation. Parameters to set apart from allow_unknown [closed]

asked 2015-06-01 18:43:16 -0600

pwong gravatar image

Hi all,

I want to make sure that the robot does not plan through the unknow regions of the map. The map looks as follows:

image description

I have set the allow unknown parameter in "base_global_planner_param.yaml" as follows:

NavfnROS:
  allow_unknown: false

and also set the track unknow region parameter in

global_costmap:
  map_type: costmap
  global_frame: map
  robot_base_frame: base_link
  track_unknown_space: true
  unknown_cost_value: 0
  update_frequency: 5.0
  static_map: true

It still plans a path as shown in above image. I have also played with unknown_cost_value parameter, (both 0 and 255), and still no avail.

The objective is to make sure that the robot does not plan apart from a specific region. I intended to edit the map so that i make all the regions grey where i do not want to plan them.

I use a preloaded map and not a live map from gmapping.

Any suggestions are appreciated.

Thanks,

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Procópio
close date 2017-05-17 01:49:38.309426

Comments

Which version of ROS?

David Lu gravatar imageDavid Lu ( 2015-06-04 21:32:37 -0600 )edit

Currently using ubuntu 14.04 and ros indigo. I think I've solved the issue, but would you mind checking out my post for a follow up question and confirm that the fix was done properly?

pwong gravatar imagepwong ( 2015-06-08 13:49:14 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-08 13:47:39 -0600

pwong gravatar image

updated 2015-09-14 19:53:29 -0600

Turns out it was a misuse of using the clear cost map service on my end which was causing the path planning issue. Adding the "base_global_plannar_params.yaml" file with "allow_unknown: false" did fix the problem. If someone can confirm this was the proper fix, please let me know.

edit flag offensive delete link more

Comments

That question is completely different from the first question; you should post it as a new question. I think the general rules of ROS Answers is to not post follow up questions in the answers.

kwiesz91 gravatar imagekwiesz91 ( 2015-09-14 18:34:03 -0600 )edit

To attempt an answer (I have yet to actually mess around with navigation, just reading a lot): The costmap is stored in layers (with one of them being the obstacle layer), I believe that you can just get rid of the obstacle layer, if that's what you want.

kwiesz91 gravatar imagekwiesz91 ( 2015-09-14 18:38:27 -0600 )edit

You're right, I should keep it focused on the original question. I'll edit my answer to not have the question, but I have resolved the issue. Thanks for taking a look at it for me, kwiesz91!

pwong gravatar imagepwong ( 2015-09-14 19:52:05 -0600 )edit

I have the same problem, I would like to ask you to solve it? How to solve?

songvanmino gravatar imagesongvanmino ( 2017-04-28 03:36:26 -0600 )edit

songvanmino, Did setting the param "allow_unknown: false" not do it for you?

pwong gravatar imagepwong ( 2017-04-28 20:09:26 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-06-01 18:43:16 -0600

Seen: 209 times

Last updated: Sep 14 '15