ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

problems compiling openni2_camera : package 'OpenNI2' not found [closed]

asked 2015-05-14 14:10:00 -0500

SpacemanSPIFF gravatar image

Hey, I am new to ROS, So kindly forgive me if this problem is too trivial.

I am trying to interface an Occipital Structure sensor with ROS. I followed a couple of tutorials few among which is

I have the Opnenni2 working and the sensor working on Ubuntu 14.04 LTS. Now I am trying to make the openni2_camera, opnnni2_launch and rgbd_launch in my catkin workspace, but the make fails as its not finding the library libopenni2 or module openni2.

Console o/p:

-- checking for module 'libopenni2'

-- package 'libopenni2' not found

-- checking for module 'OpenNI2'

-- package 'OpenNI2' not found

CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:283 (message): A required package was not found

Call Stack (most recent call first): /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:337 (_pkg_check_modules_internal) openni2_camera/CMakeLists.txt:13 (pkg_check_modules)

I read in the cmake documentation that CMake first check libraries in the ${CMAKE_MODULE_PATH} so I have also added the path where my resides. "shown below"

akshay@ubuntu:~/catkin_ws$ echo $CMAKE_MODULE_PATH


But the compilation still fails. I’m not sure, how to add the path of the library so that the dependencies are fulfilled.

Kindly HElp!!!!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SpacemanSPIFF
close date 2016-06-28 11:59:14.650872

2 Answers

Sort by » oldest newest most voted

answered 2015-05-22 13:09:00 -0500

SpacemanSPIFF gravatar image

Yeah, I tried include_directories to include the path where openni2 was built, but didn't work. I tried "sudo apt-get install ros-indigo-openni2-launch" as suggested in a few discussions, and it worked. It also installed the required dependencies so, i was able to get my occipital sensor working.

edit flag offensive delete link more

answered 2015-05-22 02:07:24 -0500

Swan Baigne gravatar image

I think you have some modifications to make to your cMakeLists.txt, like in the find_package or include_directories; or to your package.xml. You should find some help in the followings tutorials :

edit flag offensive delete link more

Question Tools


Asked: 2015-05-14 14:06:35 -0500

Seen: 2,556 times

Last updated: May 22 '15