ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problems building & running Openni2_camera

asked 2014-04-10 01:10:36 -0500

MarkyMark2012 gravatar image

Hi All,

I've managed to download and successfully compile OpenNi2 and run the sample apps.

Getting some problems with Openni2_camera however:

Compiling I get the likes of:

/home/mark/catkin_ws/devel/lib/ undefined reference to `oniStreamRegisterNewFrameCallback'
/home/mark/catkin_ws/devel/lib/ undefined reference to `oniStreamGetProperty'
/home/mark/catkin_ws/devel/lib/ undefined reference to `oniDeviceIsCommandSupported'
/home/mark/catkin_ws/devel/lib/ undefined reference to `oniDeviceSetProperty'
/home/mark/catkin_ws/devel/lib/ undefined reference to `oniReleaseDeviceList'
/home/mark/catkin_ws/devel/lib/ undefined reference to `oniStreamDestroy'
/home/mark/catkin_ws/devel/lib/ undefined reference to `oniStreamStart'
/home/mark/catkin_ws/devel/lib/ undefined reference to `oniDeviceCreateStream'

And probably related:

Running (or trying to)

rosrun openni2_camera OpenNI2.cfg

I get

Traceback (most recent call last):
File "/home/mark/catkin_ws/src/openni2_camera/cfg/OpenNI2.cfg", line 7, in <module>
  gen = ParameterGenerator()
 File "/opt/ros/groovy/lib/python2.7/dist-packages/dynamic_reconfigure/", line 234, in     __init__
self.dynconfpath = sys.argv[1]  # FIXME this is awful
IndexError: list index out of range

I'm running this with Groovy on my PC. Was to stick with Groovy ideally as I'm going to migrate it all to my Raspberry Pi

Many Thanks


edit retag flag offensive close merge delete



How did you install OpenNi2? The ROS debs are built from a fork of that - there may be modifications. Can you uninstall your source copy of OpenNi2 and `sudo apt-get install libopenni2-dev libopenni2-0`?

jbinney gravatar image jbinney  ( 2014-04-10 14:36:40 -0500 )edit

Okay just tried that and still getting the same error

MarkyMark2012 gravatar image MarkyMark2012  ( 2014-04-11 09:16:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-06-09 04:19:09 -0500

dhood gravatar image

Did you ever get around this? Cheers

edit flag offensive delete link more



Sorry for the tardy reply. Yes managed to get it build. I had to download and build OpenNI2 from scrach ( ) then made sure the pcl part of ros was built okay the finally built openni2_camera ( )

At the moment testing will let you know in the next day or so how that goes

MarkyMark2012 gravatar image MarkyMark2012  ( 2014-08-13 06:53:30 -0500 )edit

Did you manage to get this working? Ive installed Kalectros OpenNI2 and that is working but I can only build openni2_camera from kalectros repo which does not work with there anyway to use the ros-drivers openni2_camera? my raspbeery pi says cant find libopenni2?

miguel gravatar image miguel  ( 2015-08-15 04:07:13 -0500 )edit

Yes - You need to download and build OpenNI2 - It takes a while but it'll be faster on RPi2

MarkyMark2012 gravatar image MarkyMark2012  ( 2015-08-15 14:04:03 -0500 )edit

Question Tools

1 follower


Asked: 2014-04-10 01:10:36 -0500

Seen: 916 times

Last updated: Jun 09 '14