motoman controller timeout

asked 2015-03-13 10:34:39 -0500

GB_WPI gravatar image

updated 2015-03-13 10:40:44 -0500

gvdhoorn gravatar image

We are using a Motoman sda10f dual-arm robot. When attempting to move either arm to a target pose, we get a timeout error: "Controller is taking to long to execute trajectory..."

The trajectory otherwise seems to be executing as expected. Changing the rosparam 'allowed_execution_duration_scaling' does not fix the problem.

edit retag flag offensive close merge delete

Comments

Have you tried setting " ~/execution_duration_monitoring" to false (before the system is launched)? Does the motion actually occur? What node is producing the log message you mentioned?

sedwards gravatar imagesedwards ( 2015-03-13 10:57:57 -0500 )edit

That seems to have solved the problem. For the record, the motion was occurring but would stop after a few seconds before completing.

GB_WPI gravatar imageGB_WPI ( 2015-03-13 11:21:07 -0500 )edit

Did you have the speed override at a setting lower than 100%? ROS (or more precisely, MoveIt) plans at 100%, so if the robot is not at 100%, the trajectory will take longer to execute, causing the error you posted.

gvdhoorn gravatar imagegvdhoorn ( 2015-03-13 11:39:18 -0500 )edit
VictorLamoine gravatar imageVictorLamoine ( 2015-03-14 06:09:28 -0500 )edit