Ask Your Question
0

motoman stack on ros industrial

asked 2013-04-02 05:21:35 -0500

Steveb gravatar image

I am trying to install the motoman stack from ros industrial on a fuerte installation. When I compile (with a rosmake), I receive the error "Cannot find required resource: warehouse_ros". I have downloaded and installed warehouse_ros from the git repository located at https://github.com/ros-planning/warehouse_ros.git, but the problem did not go away. Any ideas?

BTW, the reason that I am doing this is to experiment with the Fast_IK solution found at http://www.ros.org/wiki/Industrial/Tutorials/Create_a_Fast_IK_Solution. However, when I installed this package, I was missing the sia10d_mesh_arm_navigation and started down a path of installing from git. Any help with the Fast_IK would also be appreciated!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-04-03 04:27:11 -0500

It appears as though you are using a groovy version of ROS-Industrial. The dependency on warehouse_ros was added for groovy. Assuming this is the case, I would recommend one of the following:

  1. Install the binary ROS-Industrial version for motoman: sudo apt-get install ros-fuerte-motoman.
  2. Install from source to get the latest functionality (i.e. close to groovy), use the fuerte dev branch: here
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-02 05:21:35 -0500

Seen: 178 times

Last updated: Apr 03 '13