Ask Your Question
0

Setup Industrial package for use of motoman driver interface with DX100 - MotoPlus

asked 2013-11-13 09:03:41 -0500

plundgren gravatar image

Running ROS Hydro, industrial core and motoman driver are downloaded from source and buildt in catkin workspace. Established connection via interface after receiving a hard coded MotoPlus application file (.out file) from Yaskawa. The one provided on github repo was not compatible with our DX100, version DS3.53.01A-14. Through joint_states topic only six joints are received, even though our robot, SIA20D, has seven axis. The names are according to the ROS-I standard, joint_1,...,joint_6. What settings are there do be done to correct this?

Have tried to rename the joints via both the provided sia20d_mesh.xml file and explicit naming. No error messages are given when these commands are performed. Though no change is noticed upon restart of interface. Why is that so?

When trying to run move_to_joint.py error message "Start and End position joint_names mismatch" is received. No matter if we name the joints according to ROS-I standard or the once that we loaded with .xml file.

Please help us out:-)!

edit retag flag offensive close merge delete

Comments

Have you followed the instructions here:http://wiki.ros.org/motoman_driver/Tutorials/Usage

sedwards gravatar imagesedwards ( 2013-11-13 14:58:16 -0500 )edit

Yes, we have. Fail to perform any of the alternatives that are given on step 3.1. Step 3.2 gives the error that was described in the question, names mismatch. Via a RosEmulator it was possible to connect to the controller state and motion server. Once connected it shows the values for seven joints.

plundgren gravatar imageplundgren ( 2013-11-14 00:06:37 -0500 )edit

@plundgren: the fact that the RosEmulator binary displayed the proper information would seem to suggest the controller side is working properly. Could you make a wireshark capture of both situations? So one when using RosEmulator, and one when connecting the ROS nodes.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-14 00:18:29 -0500 )edit

When running roscore and while loading urdf the rostopic joint_states gives us all seven value upon restart of interface. This wasn't clear in the tutorial.

plundgren gravatar imageplundgren ( 2013-11-14 03:37:00 -0500 )edit
1

My apologies. I will update the the tutorial

sedwards gravatar imagesedwards ( 2013-11-14 04:09:07 -0500 )edit

When sending move_to_joint command the pendant gives us "ERROR 0381: Robot range not checked [R1]". Servo is turned on but no motion is performed.

plundgren gravatar imageplundgren ( 2013-11-14 04:09:27 -0500 )edit

@plundgren, please ask another question about this (combining a bunch of questions into one makes the forum harder to search for others that may have a similar problem).

sedwards gravatar imagesedwards ( 2013-11-14 10:30:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-14 03:17:30 -0500

updated 2013-11-14 10:29:40 -0500

Have you tried setting the urdf or controller_joint_names parameter? The parameters must be set BEFORE the driver nodes are launched (this isn't particular clear in the tutorial: http://wiki.ros.org/motoman_driver/Tutorials/Usage). In order to do this, you will have to run roscore in it's own terminal.

edit flag offensive delete link more

Comments

Added an issue to improve the usability of the motoman launch files by adding robot specific versions (like the fanuc stack) See: https://github.com/ros-industrial/motoman/issues/18

sedwards gravatar imagesedwards ( 2013-11-15 11:32:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-11-13 09:03:41 -0500

Seen: 753 times

Last updated: Nov 14 '13