Ask Your Question
0

robot_enable error motoman

asked 2019-04-26 08:22:50 -0500

nd gravatar image

Hello,

After setting all the things with controller dx100 and driver launch, when I call rosservice robot_enable I am getting this error,

Failed to set TrajectoryMode: Not Ready (5) : Unable to enable drive power (5006)
Motoman robot was NOT enabled. Please re-examine and retry.

am I missing something to load?

thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-04-26 09:08:52 -0500

gvdhoorn gravatar image
Unable to enable drive power (5006)

From the robot controller's perspective, the ROS nodes are no different from other "external" sources of control (a PLC fi).

So all the same safety systems are in place and you need to take care of all the same safety requirements.

The error message tells you that the controller has determined that it cannot enable motor power and therefore the robot_enable service call returns an error.

The Usage: Robot Controller section of the Using the Motoman FS/DX/YRC ROS Interface tutorial lists the minimum requirements for external control to be possible:

Prior to executing ROS motion:

  1. Make sure the robot controller is ready:
    • Installation and setup of MotoROS driver must be complete
    • Pendant key switch must be in Remote mode
    • The E-stop latch must be released

Furthermore the standard safety conditions must be met: any fences closed, all e-stops released (also external ones), and no inhibiting devices (ie: a PLC) can be actively keeping the robot in an error state.

edit flag offensive delete link more

Comments

@gvdhoorn prior to executing ROS motion minimum requirements I have checked and its all ok. Also, I found that no one has experience this type of error on github issues and google groups.

so, how can I solve this?

nd gravatar imagend ( 2019-04-26 13:39:10 -0500 )edit

Can you enable your servos manually with the Pendant in Remote mode?

gvdhoorn gravatar imagegvdhoorn ( 2019-04-26 14:23:10 -0500 )edit

that I will check on monday and let you know, as I don't have access right now due to weekend.

nd gravatar imagend ( 2019-04-26 14:31:20 -0500 )edit

thank you. the reason was this, "safety guard is open", after closing this it is working.

nd gravatar imagend ( 2019-04-29 01:52:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-04-26 08:22:50 -0500

Seen: 38 times

Last updated: Apr 26