Ask Your Question
0

Unable to cakin_make openni2_camera.

asked 2015-01-22 03:55:45 -0500

Xin gravatar image

Hi, I am using Odroid XU3, with ubuntu 12.04(precise) and ROS(Hydro). I've got OpenNI2 installed on my Home folder, and I can run openni2_example from odroid-development. But when I catkin_make, there is the error of [package 'libopenni2' not found] and [package 'openni2' not found]. Have you encountered this problem before? Can you suggest a solution for me to fix this problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-24 23:12:50 -0500

fergs gravatar image

You'll need to isntall libopenni2 -- under ubuntu/debian you should be able to install the package libopenni2-dev if it is build for your platform, otherwise, you will need to build from source, I believe the hydro releases were built from: https://github.com/hcw70/OpenNI2

edit flag offensive delete link more

Comments

I tried to install libopenni2-dev but I got this

Package libopenni2-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libopenni2-dev' has no installation candidate

Xin gravatar image Xin  ( 2015-01-25 21:38:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-01-22 03:55:45 -0500

Seen: 354 times

Last updated: Jan 24 '15