Ask Your Question
0

Running distributed RGBDSLAM [closed]

asked 2014-06-12 01:15:08 -0600

rigeeeeel gravatar image

updated 2014-06-14 22:07:20 -0600

I am having the same problem as the one title "Running rgbdslam over multiple machines":

"

Hi,

I am trying to run rgbdslam over a distributed ROS system, running the openni nodes on a laptop aboard an iRobot Create with a kinect and running rgbdslam on a desktop computer. When I run rosrun rgbdslam rgbdslam (or roslaunch rgbdslam kinect+rgbdslam, or a modified launch file I made that is the same as kinect+rgbdslam but doesn't start the openni stuff), the GUI loads fine, I get no errors, but it always sits with blank screens in a 'waiting for image/motion' state.

Both computers can ping and ssh into each other and other applications (such as gmapping, amcl, and others) work fine when distributed like this (the data collection and minimal processing on the laptop, and heavier processing on the desktop). Furthermore, I can view the various camera streams from the kinect on the default topics on the desktop with image_view. I also can view rxgraph and the info on the various topics that rgbdslam needs and it all appears fine (identical to when I run everything on the desktop and it works).

Furthermore, as implied by the above comment, I can run rgbdslam on the desktop with a handheld kinect and it works fine.

The desktop and laptop are both running x64 Lubuntu 11.10. We're using ROS electric, and the current builds of rgbdslam and openni.

Is there any reason rgbdslam will not work distributed like this, or am I just doing something wrong?

Thanks in advance

"

But I am using openni2_camera by kalectro on my odroid u3 because I couldn't stream the depth at rgb images at the same time and this fixed that problem. (github/kalectro/openni2_camera)

I am also using ros hydro on my odroid u3 and fuerte on my laptop. I edited the openni_launch to not include the openni_camera node.

I run the openni2_camera_node on my odroid and run my edited openni_launch and rgbdslam on my laptop. Viewing interconnections through rxgraph make everything seem in order, I can also view the inputs through image_view to rgbdslam such as the camera/rgb/image_rect_color and camera/depth_registered/image_rect.

However in my openni_launch I get these repeated warnings:

[ WARN] [1401676151.213846313]: [image_transport] Topics '/camera/depth/image_raw' and '/camera/depth/camera_info' do not appear to be synchronized. In the last 10s:
Image messages received: 35
CameraInfo messages received: 213
Synchronized pair: 3

[WARN] [1401676152.345141890]: TF exception:
Frame id /openni_rgb_optical_frame does not exist! Frames (6): Frame /camera_depth_frame exists with parent /camera_link.
Frame /camera_link exists with parent NO_PARENT.
Frame /camera_rgb_frame exists with parent /camera_link.
Frame /camera_depth_optical_frame exist with parent /camera_depth_frame.
Frame /camera_rgb_optical_frame exists with parent /camera_rgb_frame.

I tried to use timeSync but it still is not working with the rgbdslam however, when using the timeSync there are no more warnings. I've been trying to make this work for quite a while now. Help would be much appreciated. :)

Thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-11-02 01:43:45.400216

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-20 07:45:49 -0600

What happens if you record the topics with rosbag on your laptop and run rgbdslam on the bagfile?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-06-12 01:15:08 -0600

Seen: 452 times

Last updated: Jun 20 '14