ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem in Using more than one directory in fuerte

asked 2015-01-21 12:20:29 -0600

Morteza gravatar image

updated 2015-01-21 12:20:52 -0600

Hi everyone,

I have installed hydro and fuerte and having problem when i want to use more than one directory in fuerte. I have made 2 directories named,fuerte_workspace and ros_workspace, and added them to my bashrc. but my ROS doesn't seem to recognize my ros_workspace and I can just roscd to packages in fuerte_workspace. what shoul I do? Thanks for any help. My ending lines in bashrc are as follows:

 source `rospack find gazebo`/setup.bash
 source /opt/ros/fuerte/setup.bash
 export ROS_PAcKAGE_PATH=~/dev/rosbook:$ROS_PACKAGE_PATH
 export ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH
 export ROS_PACKAGE_PATH=~/fuerte_workspace/sandbox:$ROS_PACKAGE_PATH
 export ROS_PACKAGE_PATH=~/drh-robotics-ros/ros/ardros:$ROS_PACKAGE_PATH
 export ROS_PACKAGE_PATH=~/fuerte_workspace/sandbox/VSLAMDIR:$ROS_PACKAGE_PATH
 export ROS_PACKAGE_PATH=~/fuerte_workspace/sandbox/Navigation_Mohammad:$ROS_PACKAGE_PATH

 source /opt/ros/hydro/setup.bash
 source /opt/ros/hydro/setup.bash
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-01-21 13:36:09 -0600

You first source the fuerte setup.bash, then add stuff to ROS_PACKAGE_PATH and afterwards source the hydro setup.bash. If I'm not mistaken, that overwrites your ROS_PACKAGE_PATH settings from before. You'll want to first call setup.bash files and afterwards set ROS_PACKAGE_PATH. You also have a typo in your first export line (lower case "c").

It's generally advisable to use rosinstall and wstool for setting up a workspace, as this means you don't have to manually define ROS_PACKAGE_PATH as you have done. See for example this Q/A.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-01-21 12:20:29 -0600

Seen: 93 times

Last updated: Jan 21 '15