Ask Your Question
1

"No ROS_WORKSPACE set" - Problem

asked 2012-10-26 06:51:55 -0500

viovio gravatar image

updated 2014-01-28 17:14:04 -0500

ngrennan gravatar image

Hello,

I want to use roscd inside of my ros_workspace, without typing:

source ~/fuerte_workspace/setup.bash

at first. In this tutorial is written:

It is very common to replace the line source /opt/ros/fuerte/setup.bash to source the setup.bash in ~/fuerte_workspace.

I suspect that this sentence is the solution. Due to English is not my Motherlanguage I just dont get it what to do in order to use roscd instantly for all packages inside of my fuerte_workspace.

Can someone please give me an exact instruction to reach my goal?

Thanks in advance Dominik

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-10-26 07:21:48 -0500

updated 2012-10-26 07:22:32 -0500

Hi, hopefully this helps you out.

From my personal experience (on Ubuntu) I've found that adding the following lines to my ~/.bashrc file keeps everything for me in working condition:

source /opt/ros/fuerte/setup.bash
export ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH
export ROS_WORKSPACE=~/ros_workspace

and in your case I think you would want it to be:

source ~/fuerte_workspace/setup.bash
export ROS_PACKAGE_PATH=~/fuerte_workspace:$ROS_PACKAGE_PATH
export ROS_WORKSPACE=~/fuerte_workspace

That should let you use roscd and other ros command line tools with your setup.

edit flag offensive delete link more

Comments

Did you meant the bash.bashrc file under /etc? Because I found 3 aditional files with bashrc in it. I could change this file (under /etc) only with root-permissions. But after modifying the file nothing changed.

viovio gravatar image viovio  ( 2012-10-26 09:12:19 -0500 )edit
1

It should not be necessary to set ROS_PACKAGE_PATH or ROS_WORKSPACE in your .bashrc. Try only "source ~/fuerte_workspace/setup.bash", this should work as well.

KruseT gravatar image KruseT  ( 2012-10-26 10:08:26 -0500 )edit

Exactly this is the problem. I don't want to type this line everytime in a new console when i want to roscd a package out of my workspace. I know it must be possible (in another vmware image it is like that).

viovio gravatar image viovio  ( 2012-10-26 10:37:39 -0500 )edit
1

I think what KruseT was saying is that you don't need all the lines I put in there. Only the first. This goes in the file .bashrc in your user's home directory, which is what the prefix ~ means. Every time you open a new terminal, that will be loaded and you won't need to type it.

skiesel gravatar image skiesel  ( 2012-10-27 11:14:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-26 06:51:55 -0500

Seen: 898 times

Last updated: Oct 26 '12