Ask Your Question
1

No ROS_WORKSPACE set- error

asked 2013-02-10 07:50:22 -0600

TheSkyfall gravatar image

updated 2014-01-28 17:15:11 -0600

ngrennan gravatar image

Hello, I have been trying to create a ros workspace according to ROS tutorials. First, I got this error

ERROR in config: Command requires a target workspace.

exactly the same situation in this question

rosws problem fuerte

then I fixed it and I got the following output:

rosws set sandbox

     Add new elements:
  sandbox

Continue: (y)es, (n)o: y
Overwriting /home/turtlebot/groovy_workspace/.rosinstall

Do not forget to do ...
$ source /home/turtlebot/groovy_workspace/setup.sh
... in every open terminal.

But now when I try roscd command, I get this error

No ROS_WORKSPACE set. Please set ROS_WORKSPACE to use roscd with no arguments.

Any idea why?

Thank you.

edit retag flag offensive close merge delete

Comments

Boris gravatar imageBoris ( 2013-02-10 17:50:49 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
4

answered 2013-02-10 10:03:15 -0600

KruseT gravatar image

updated 2013-02-11 20:42:56 -0600

This is a current bug in rosws, fiexed already to be released soon. In the meantime you can edit your setup.sh, and copy the line exporting ROS_WORKSPACE to the bottom of the file (copy, not move). That should fix the behavior until the fix is out. Note the setup.sh files only get updated by rosws when you run rosws regenerate.

UPDATE (thanks Boris): Add the following line at the bottom of your ~/.bashrc

export ROS_WORKSPACE=/home/turtlebot/groovy_workspace

This line should already be at the top of the file, but the value gets removed in between. Others have to adapt the path, obviously.

edit flag offensive delete link more

Comments

Thank you. It works.

TheSkyfall gravatar imageTheSkyfall ( 2013-02-13 12:07:15 -0600 )edit
0

answered 2013-02-10 10:48:38 -0600

TheSkyfall gravatar image

Thanks kruseT, What do you mean by "the line exporting ROS_WORKSPACE" ? How may I know when the problem get fixed?

Thank you.

edit flag offensive delete link more

Comments

Please use comments for discussions instead of "Your answer" form. Regarding ROS_WORKSPACE add the following line at the bottom of your ~/.bashrc - export ROS_WORKSPACE=/home/turtlebot/groovy_workspace.

Boris gravatar imageBoris ( 2013-02-10 17:49:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-10 07:50:22 -0600

Seen: 864 times

Last updated: Feb 11 '13