Ask Your Question
1

trouble creating sandbox in groovy [closed]

asked 2013-02-06 13:22:30 -0600

richkappler gravatar image

updated 2014-01-28 17:15:08 -0600

ngrennan gravatar image

Trying to install groovy on a 64 bit HP G62 running Ubuntu 12.04. Followed installation instructions up to 4.2 Creating a sandbox directory for new packages.

Under 4.1 Creating a new workspace, I changed out rosws init ~/fuerte_workspace /opt/ros/fuerte to rosws init ~/groovy_workspace /opt/ros/groovy

$echo ROS_PACKAGE_PATH returned /opt/ros/groovy/share:/opt/ros/groovy/stacks

I checked in the home folder and groovy_workspace was indeed created. Sandbox folder was created in the groovy_workspace folder. Thinking it odd that my package path didn't match, I continued on to the the tutorials to see what would happen.

Had no problems until I got to the point where it tells you to run roscd by itself.

this is what I got: No ROS_WORKSPACE set. Please set ROS_WORKSPACE to use roscd with no arguments.

tried the whole procedure again but as written in the wiki, not substituting groovy for fuerte, same result. (fuerte_workspace created, sandbox inside, but all else exactly the same). Not sure what I'm doing wrong, would appreciate some guidance.

regards, Richard

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by richkappler
close date 2013-12-28 08:07:37

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-02-06 14:25:13 -0600

updated 2013-02-06 14:38:11 -0600

Looks like a bug. I tried to replicate the problem and can confirm the same behaviour.

Seems the issue is somewhere in setup.sh and/or in the files it implicitly sources. It unsets the ROS_WORKSPACE variable exported at the beginning. Even if you specify ROS_WORKSPACE by hand it will be deleted after sourcing the setup.bash.

To make roscd work without arguments I can suggest you to set ROS_WORKSPACE explicitly in your .bashrc after the line that sources the relevant setup file.

EDIT: opened a ticket.

edit flag offensive delete link more
1

answered 2013-02-06 20:45:33 -0600

KruseT gravatar image

Yes, this is a bug in rosinstall, where ROS_WORKSPACE needs to be set after it has been unset by the catkin setup.sh. https://github.com/vcstools/rosinstall/issues/57 You can as a workaround also export ROS_WORKSPACE again at the bottom of the setup.sh in your rosbuild workspace.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-02-06 13:22:30 -0600

Seen: 315 times

Last updated: Feb 06 '13