ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ros as root - common bug, when workspace is in /home/user/ros_workspace

asked 2012-06-11 21:19:45 -0600

Flowers gravatar image

updated 2014-01-28 17:12:38 -0600

ngrennan gravatar image

Hey guys,

I tried to run some ROS-Packages as root and got this:

Warning: error while crawling /home/username: boost::filesystem::status: Permission denied: "/home/username/.gvfs"

According to some google research, this is a common bug - somehow .gvfs denies any access for anyone who is not the user.

My setup of shell&environment was absolutly fine, once I copied the workspace to another path(/home/ros_workspace) there was no problem :-)

This is no real question, but I thought it might be helpful to mention this problem.

edit retag flag offensive close merge delete


Probably best to file a bug instead:

Asomerville gravatar image Asomerville  ( 2012-06-12 04:25:49 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2012-06-11 22:41:27 -0600

dornhege gravatar image

Why are you running ROS packages as root from the workspace of another user? That is likely that actual problem.

edit flag offensive delete link more



Because I thought it would be useful in that situation ;-) and the system has one user(me) and root...usually root should have access to everything which it has not, so I reported this.

Flowers gravatar image Flowers  ( 2012-06-12 01:41:03 -0600 )edit

Good to be aware of. The message is "don't run as root", and especially "don't build anything as root".

joq gravatar image joq  ( 2012-06-12 02:21:30 -0600 )edit

answered 2012-06-12 03:12:54 -0600

Flowers gravatar image


You actually can start from /home/user/.../ros_workspace, still some features are not available due to the bug(e.g. using tab to auto-complete commands and package-names).

edit flag offensive delete link more

Question Tools


Asked: 2012-06-11 21:19:45 -0600

Seen: 1,802 times

Last updated: Jun 12 '12