Ask Your Question
0

Waiting for the joint_trajectory_action server

asked 2014-10-13 15:48:31 -0500

Fred Eduardo gravatar image

updated 2014-11-22 17:05:54 -0500

ngrennan gravatar image

Hey Guys, I am trying to do some demos on a real Pr2, but I cant make it move it arms.

At first, I tried http://wiki.ros.org/pr2_interactive_m... And there occurs no error, robot comes up and on my desktop, rviz shows up all Ok, but then when I try to move its arms to the front or so it doesnt move.

So I tried something even more basic: pr2_props On Robot roslaunch pr2_props pr2_props.launch And on the desktop rosrun pr2_props hug

But I keep getting this message on a loop:

[ INFO] [1413233159.293564120]: Waiting for the joint_trajectory_action server
[ INFO] [1413233164.293692161]: Waiting for the joint_trajectory_action server
[ INFO] [1413233169.293832716]: Waiting for the joint_trajectory_action server
[ INFO] [1413233174.293930410]: Waiting for the joint_trajectory_action server

Any ideas what it could be?

@pr1023:~$ rosrun pr2_controller_manager pr2_controller_manager list
base_controller ( running )
base_odometry ( running )
head_camera_trigger ( running )
head_traj_controller ( running )
l_arm_controller ( running )
l_forearm_cam_trigger ( running )
l_gripper_controller ( running )
laser_tilt_controller ( running )
projector_controller ( running )
projector_trigger ( running )
prosilica_inhibit_projector_controller ( running )
r_arm_controller ( running )
r_forearm_cam_trigger ( running )
r_gripper_controller ( running )
torso_controller ( running )

these are my controllers. is it how it is supposed to be or am I missing something?

edit retag flag offensive close merge delete

Comments

This could be a network problem. Does it work if you run everything on the robot?

ahendrix gravatar image ahendrix  ( 2014-10-14 14:37:28 -0500 )edit

Well, tuckarms work just fine. Could this be a network problem just for the controllers? Cause, on the desktop, using pr2_interactive_manipulation, Rviz shows correct information/states of the robot, so it receives data on the network. When I click 'move right arm', however, then it doesnt work.

Fred Eduardo gravatar image Fred Eduardo  ( 2014-10-15 10:29:27 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-10-14 05:50:12 -0500

Adolfo Rodriguez T gravatar image

Your PR2 doesn't seem to be running the expected controllers. The instructions can either be out of date (note that Groovy is already EOL'ed), or your PR2 bringup logic does not coincide with the expectations of the demo instructions. You can query the list of running and stopped controllers by running

rosservice call /pr2_controller_manager/list_controllers

If the expected controllers are there, but stopped, you should just start them, otherwise you might have to load their configuration to the param server, load the controllers, and then start them.

edit flag offensive delete link more

Comments

On the PR2, you get much better output by using the pr2_controller_manager: rosrun pr2_controller_manager pr2_controller_manager list

ahendrix gravatar image ahendrix  ( 2014-10-14 13:05:40 -0500 )edit
1

answered 2014-10-15 10:45:55 -0500

ahendrix gravatar image

It's quite possible that topics only work in one direction (from the robot to your desktop, but not back).

For more information, go watch my ROSCon talk from 2013: https://vimeo.com/67806888

edit flag offensive delete link more
1

answered 2014-10-15 11:05:48 -0500

Fred Eduardo gravatar image

updated 2014-10-15 13:53:00 -0500

Yeah! after seeing your video I figured it out. My desktop could reach the Pr2 (Of course), but c1 could not reach my desktop. So I just added it to the hosts file and now everything works. Thanks a lot man! awesome talk!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-13 15:48:31 -0500

Seen: 715 times

Last updated: Oct 15 '14