ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

error in rosdep initialization

asked 2014-09-27 03:33:36 -0600

ama gravatar image

updated 2014-09-27 06:49:13 -0600

When i tried to initialize rosdep, (xubuntu 14.04 is installed.)

sudo rosdep init

It gives following error

ERROR: cannot download default sources list from: Website may be down.

My proxies are correct. Any idea what is wrong?

edit retag flag offensive close merge delete


What do you mean by "My proxies are correct" ?

marcobecerrap gravatar image marcobecerrap  ( 2016-05-18 04:21:05 -0600 )edit

5 Answers

Sort by ยป oldest newest most voted

answered 2015-03-05 17:05:10 -0600

tfoote gravatar image

updated 2015-03-05 17:05:30 -0600

sudo by default does not preserve environment. You need to use the -E option to preserve the environment which is where I presume you're setting up your proxies. Use:

sudo -E rosdep init

Related question:

edit flag offensive delete link more

answered 2015-03-05 01:14:28 -0600

Amina gravatar image

The following works for me: 1. sudo su 2. sudo rosdep init 3. Ctrl-D 4. rosdep update In case this error:

ERROR: error loading sources list: (>

try rosdep update again

edit flag offensive delete link more

answered 2014-09-27 14:47:15 -0600

Aracanid gravatar image

Manually creating each file and pointing to them using file:// and their path instead of the web URL as tfoote suggested has solved this problem but hasn't improved my situation much.

If you just open the raw github link that it returns in your error code (i.e. // and copy its contents into a file called 20-default.list in /etc/ros/rosdep/sources.list.d/ then you should be able to skip the rosdep init step and proceed to rosdep update.

As you'll see after this you will have to indivdually do this for each link inside 20-default.list so I'm still stuck but slowly working through my problems. Hopefully this helps you and thank tfoote for suggesting the fix. If I manage to figure out anything else I'll let you know

edit flag offensive delete link more

answered 2016-01-19 06:29:49 -0600

Petros gravatar image

Hello! I have found the reason:

@ama wrote: "My proxies are correct."

My problem appeared after proxy setup, so I was looking into the problem.

In my environment I had "https_proxy" and "HTTPS_PROXY" declared with an empty string. All the tools, apt, wget, curl works fine with this, but rosdep init AND rosdep update fails (version 0.11.4 here)

So you just have to unset these, and voila...

edit flag offensive delete link more


Could you please descrive how to do this. I mean which commands are used please? Thx

marcobecerrap gravatar image marcobecerrap  ( 2016-05-18 04:17:54 -0600 )edit

answered 2015-05-11 23:35:17 -0600

htlbydgod gravatar image

First, you should remove the /etc/ros/rosdep/sources.list.d/20-default.list; and then do this ''sudo rosdep init''. I work it out, you can try it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-09-27 03:33:36 -0600

Seen: 8,665 times

Last updated: Jan 19 '16