Ask Your Question

Getting uEye camera to interface with Aruco / OpenCV

asked 2014-08-18 14:12:28 -0500

hdejarnette gravatar image

Hello everyone, I have been trying to get the uEye camera to interface with the OpenCV library Aruco, following the instructions here: . I have made it to the last line, $ ./aruco_test_board live board.yml camera.yml 0.025 but evertime I run it I get Could not Open Video. My uEye camera works with its own demos and ImageView, and shows up as ueye under ls /dev. I have tried on two machines, running Ubuntu 12.04 and 14.04, ROS Hydro and Indigo respectively. Same error for both. Does anyone know how to resolve this?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-07-08 17:26:55 -0500

anqixu gravatar image

uEye cameras use a proprietary communication protocol (and driver daemon), which OpenCV does not support.

Consider using a ROS dirver for uEye (I recommend ueye_cam :D), and also see

edit flag offensive delete link more

answered 2014-08-19 06:24:36 -0500

davinci gravatar image

Aruco is probably looking for a /dev/video* entry while yours is /dev/ueye you should change that in the configuration or remap it somehow.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2014-08-18 14:12:28 -0500

Seen: 1,361 times

Last updated: Jul 08 '15