ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error when running rviz "undefined symbol error: /opt/ros/hydro/lib/ undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEEb"

asked 2014-07-02 08:02:06 -0500

aboosaa gravatar image

updated 2014-07-02 08:06:11 -0500

This is different from the solutions and questions that are already asked. I even tried to fix this with the already existing solutions although there differed by the "/opt/ros/hydro/lib/ undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEEb" part of the error message.

The whole cmd line says:

developer@haf:~/catkin_ws$ rosrun rviz rviz /opt/ros/hydro/lib/rviz/rviz: symbol lookup error: /opt/ros/hydro/lib/ undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEEb developer@haf:~/catkin_ws$

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-07-02 11:01:26 -0500

ahendrix gravatar image

I saw something similar recently. Try upgrading your installed versions of roslib and rviz to the latest versions:

sudo apt-get install ros-hydro-rviz ros-hydro-roslib
edit flag offensive delete link more


Also, doing a dist-upgrade helps most often.

McMurdo gravatar image McMurdo  ( 2014-07-03 05:53:38 -0500 )edit

Thanks Austin!

sudo apt-get install ros-hydro-roslib

worked for me

Dani C gravatar image Dani C  ( 2015-02-18 11:36:23 -0500 )edit

Question Tools


Asked: 2014-07-02 08:02:06 -0500

Seen: 1,082 times

Last updated: Jul 02 '14