Ask Your Question
0

Is it possible to connect machines with different ros versions?

asked 2013-11-22 04:31:42 -0500

rilke gravatar image

I am running a robot pc (NUC) with ros-fuerte and my laptop with ros-hydro. I want to run the main nodes on the robot and the debugging nodes like rqt_plot and some hand made GUIs that use services on my laptop. Following the instructions from the ros wiki on NetworkSetup and MultipleMachines everything gets started and I can see all services and topic doing rostopic/rosservice list on both machines. But if I start my debugging nodes on the laptop (the robot fuerte is running the roscore) the topics and services from the robot seem not reachable. It just doesn't work, I mean there is no output saying connection failed or anything. Only if I try rosservice info <my_service> it says:

Node: /motor_control URI: rosrpc://NUC:47241 ERROR: Unable to communicate with service [/motor_control/SpeedLeftGainControl], address [rosrpc://NUC:47241]

Can this be due to discompabilities between fuerte and hydro? I have no other idea, since everything else works like described.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-22 05:41:19 -0500

Dirk Thomas gravatar image

As long as the specific messages have not been changed between the two ROS distributions (which is only rarely the case) it should be work fine. One likely problem you are running into is that one of your computers can not resolve the other one without some more hints. Please read http://wiki.ros.org/ROS/NetworkSetup and see if setting ROS_IP / ROS_HOSTNAME makes it work for you.

edit flag offensive delete link more

Comments

I tried to set either ROS_IP or ROS_HOSTNAME but it did only produce further errors. What solved it for me was to define the mapping between ip and hostname in /etc/hosts

rilke gravatar imagerilke ( 2013-11-25 22:51:04 -0500 )edit

Since the mapping in your hosts file worked it is very likely that you have set the ROS_IP / ROS_HOSTNAME variables wrong. You might either want to keep using the host file approach or try getting the environment variable to work. May be this similar questions provides you with the necessary hints: http://answers.ros.org/question/9915/ros-mutiple-machine/

Dirk Thomas gravatar imageDirk Thomas ( 2013-11-26 05:42:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-22 04:31:42 -0500

Seen: 2,534 times

Last updated: Nov 22 '13