pioneer 3dx caster wheel spins in place when simulating in gazebo [closed]

asked 2012-08-28 14:33:26 -0500

aecins gravatar image

updated 2012-08-28 14:35:47 -0500

I am trying to simulate Pioneer 3dx robot in gazebo (running Fuerte). When I launch the simulation the robot spawns but then the caster wheel starts spinning in place. It accelerates and after some time the back side of the robot starts to "sink" into ground in gazebo window. I can not figure out why. Same urdf model worked fine in Diamondback. I ran erratic robot simulation (which is differential drive as well) in Fuerte and it works fine, but I could not find why it doesn't work for Pioneer.

Here are the urdf files I am using
pionner3dx body
pionner3dx wheel
Differential drive plugin

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-01-26 14:01:44


is this taken from the p2os repo? ( Will this repo demonstrate the same error?

hsu gravatar image hsu  ( 2012-08-29 14:04:12 -0500 )edit

I am running a modified version of p2os repo code. The main difference is that I am using the differential drive gazebo plugin from erratic robot. I got pioneer3DX to simulate correctly in Diamondback. I am not sure how the p2os repo code will behave under Fuerte.

aecins gravatar image aecins  ( 2012-08-30 11:12:21 -0500 )edit

in which case, is your repo public? It would be much easier for me (and others) to reproduce the error that way, as opposed to copy/paste files and updating file/package names in misc. places, etc. :)

hsu gravatar image hsu  ( 2012-08-30 11:41:19 -0500 )edit

The repository is not public yet but here's a link it's current version ( To run gazebo simulation run roslaunch p2os_description pioneer3dx_gazebo.launch And thanks for the effort!

aecins gravatar image aecins  ( 2012-08-31 07:28:48 -0500 )edit