ros2 topic echo joy works inconsistently across two machines

asked 2021-12-26 15:38:42 -0500

Sc20d gravatar image

I have two machines set up on the same network, both running Ubuntu 20.04 and Foxy. The laptop has a Logitech Wingman Extreme joystick attached to it via USB and is publishing via joy node. A Raspberry Pi 3 is trying to listen for joystick input and use it to control some motors on a wheeled robot. Both are set up via Wi-Fi on the same network.

When I run ros2 topic echo joy on the laptop, I have no problems seeing joystick commands consistently.

When I do the same on the R PI, I get very inconsistent results. Usually, it will just sit there for several minutes and then all of a sudden start displaying joystick data without my having changed anything on either machine. I can CTRL-C to stop it and immediately run the same command. Sometimes it starts right up again, sometimes it just sits there, and sometimes it takes several minutes again before starting to display the joystick data.

Both machines can ping each other via IP address and name with no issues. (I added entries into /etc/hosts on both machines pointing names to IP addresses.) As far as I can tell, there are no firewall issues standing in the way of communication. I have verified that multicast is enabled. The R PI shows the topic when I run ros2 topic list and ros2 topic info /joy.

I’m rather new to troubleshooting on UBUNTU and ROS, so any help with troubleshooting this inconsistency would be appreciated.

edit retag flag offensive close merge delete


What's is your CPU load in RPI when performing the task? And how much memory you have in the RPi 3?

osilva gravatar image osilva  ( 2021-12-27 13:07:25 -0500 )edit