Ask Your Question
2

Turtlebot electric service does not start properly

asked 2012-02-07 08:58:36 -0500

Aroarus gravatar image

updated 2012-03-27 13:56:28 -0500

I am running electric on my turtlebot, and when the turtlebot laptop boots up, the turtlebot service starts, but the dashboard remains grey, with no input from the turtlebot. The only way I can get the turtlebot to do something is to stop the service and roslaunch something like minimal.launch or the teleoperation stack. Any ideas as to why the service might not be doing anything at the beginning? I have tried waiting up to 15 minutes for it to start up properly, with no results. Restarting the service does not work either, it just produces the same stale result on the dashboard. This is a followup to this post: http://answers.ros.org/question/3743/turtlebot-restarting-continuously which I thought fixed my problems, but I have not been able to duplicate the result of electric starting the turtlebot correctly after that initial success.

The problem still exists, and this is my current launch file:

<launch>
  <param name="turtlebot_node/gyro_scale_correction" value="1.0"/>
  <param name="turtlebot_node/odom_angular_scale_correction" value="1.0"/>

  <include file="$(find turtlebot_bringup)/minimal.launch">
    <arg name="urdf_file" value="$(find xacro)/xacro.py '$(find turtlebot_arm_description)/urdf/arm.urdf.xacro'" />
  </include>

</launch>
edit retag flag offensive close merge delete

Comments

1

okay.. can you check that nothing is wrong with the launch file in /etc/ros/electic

mmwise gravatar image mmwise  ( 2012-02-13 13:44:11 -0500 )edit

I have updated the post.

Aroarus gravatar image Aroarus  ( 2012-03-27 13:56:55 -0500 )edit

I had the same problems with electric version. Diamondback is good. I reverted to diamondback and everything works fine.

McMurdo gravatar image McMurdo  ( 2012-03-28 01:20:23 -0500 )edit

Unfortunately I need electric for the arm that I am using :(

Aroarus gravatar image Aroarus  ( 2012-03-28 08:33:56 -0500 )edit

which version of electric are you using? is your wireless interface set properly? Do you see any errors in the dashboard?

mmwise gravatar image mmwise  ( 2012-03-28 18:38:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-02 17:50:47 -0500

mmwise gravatar image

updated 2012-04-02 17:52:13 -0500

Ahhh... I know what's wrong! When we did the latest release the urdf files changed around and the urdf for the arm didn't update to reflect the new files. So when you launch the arm it can't find the urdf file it's looking for.. I just fixed it in electric. You can edit the arm.urdf.xacro file to read:

<include filename="$(find turtlebot_description)/urdf/turtlebot.urdf.xacro" />

I released the update in turtlebot_arm 0.1.1, it should be in debian soon.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-02-07 08:58:36 -0500

Seen: 403 times

Last updated: Apr 02 '12