Error opening turtlebot_dashboard [closed]

asked 2011-10-03 23:18:59 -0600

Catotaku gravatar image

Hi all!

We have recently bought a turtlebot, we are following all the steps of the tutorial

turtlebot tutorials

Now we are stacked in bring up step.

We run the dashboard in the external computer, and we can see at the diagnostic panel 3 errors.

/Digital I/O : Stale
/Mode : Stale
/Sensor : Stale

After this errors, We check if the computer is able to find the board in the devices.

We find it in /dev/USB0.

The last thing we have tried is execute the driver.launch of the package turtlebot_bringup. And we have the following error :

process[turtlebot_node-1]: started with pid [3521]
[INFO] [WallTime: 1317726385.551071] serial port: /dev/ttyUSB0
[INFO] [WallTime: 1317726385.551577] update_rate: 30.0
[INFO] [WallTime: 1317726385.551997] drive mode: twist
[INFO] [WallTime: 1317726385.552529] has gyro: True
Failed to contact device with error: [Error reading from SCI port. No data.]. Please check that the Create is powered on and that the connector is plugged into the Create.
[turtlebot_node-1] process has finished cleanly.

Each time we try to connect to the board the roombla is switched on.

You have any suggestion of what can be wrong? or anyone have found the same problem and solved.

thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by tfoote
close date 2012-08-15 08:24:15


try sudo chmod a+rw /dev/ttyUSB0.. you may not have read/write permissions
mmwise gravatar image mmwise  ( 2011-10-14 08:45:25 -0600 )edit
actually, is the device on /dev/USB0 or on /dev/ttyUSB0... as you can see from the console output it's expecting to find the device at /dev/ttyUSB0
mmwise gravatar image mmwise  ( 2011-10-14 08:46:55 -0600 )edit
did this work for you?
mmwise gravatar image mmwise  ( 2011-11-26 10:33:49 -0600 )edit

The problem is solve, the proublem cames because we were not using a create roomba, we use an european roomba and we have to change the baud rate, and also the board we use to connect to the roomba.

If someone is using a eurpean roomba I will recomend to check the roomba stack

Catotaku gravatar image Catotaku  ( 2012-03-27 03:45:14 -0600 )edit