Ask Your Question
0

More TurtleBot_dashboard problems

asked 2011-09-06 15:54:43 -0500

ParkerGibbons gravatar image

Now I can get the dashboard pulled up on my turtle bot computer, but not my workstation. In addition, I have no idea how to change the ROS Master URI to the TurtleBot. Please help, I think I am almost at the point to start working on my robotics project!

-Parker

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-09-06 16:01:28 -0500

mmwise gravatar image

updated 2011-09-06 16:03:06 -0500

Watch the TurtleBot dashboard video: http://www.youtube.com/watch?v=wDU1Wc9SO7Q.

To set your ROS_MASTER_URI

export ROS_MASTER_URI=http://<TURTLEBOT_IP>:11311

replace < TURTLEBOT_IP > with the IP address of the TurtleBot

to determine the IP address of the TurtleBot

ifconfig

you should see something similar to:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:36800562 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36800562 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3320894268 (3.3 GB)  TX bytes:3320894268 (3.3 GB)

wlan0     Link encap:Ethernet  HWaddr 48:5d:60:7d:22:e6  
          inet addr:10.0.129.60  Bcast:10.0.129.255  Mask:255.255.254.0
          inet6 addr: fe80::4a5d:60ff:fe7d:22e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:475034 errors:0 dropped:0 overruns:0 frame:0
          TX packets:292561 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:360404726 (360.4 MB)  TX bytes:49527301 (49.5 MB)

in the above case < TURTLEBOT_IP >=10.0.129.60

edit flag offensive delete link more

Comments

@ParkerGibbons did this help you?
mmwise gravatar image mmwise  ( 2011-09-07 03:25:31 -0500 )edit
@mwise_wg It has helped me set the URI, but I still can't get the dashboard to open on my workstation. I get the message
ParkerGibbons gravatar image ParkerGibbons  ( 2011-09-09 10:54:40 -0500 )edit
" Unable to access the X Display, is $DISPLAY set properly?", when I type "rosrun turtlebot_dashboard turtlebot_dashboard&". What is wrong?
ParkerGibbons gravatar image ParkerGibbons  ( 2011-09-09 10:56:20 -0500 )edit
1
ahhh you're trying to view the dashboard over ssh.. typically you would install ros-diamondback-turtlebot-desktop on your workstation computer and run the dashboard locally (on the workstation computer) in order to do it over ssh you need to to X forwarding by doing ssh -X when ssh-ing
mmwise gravatar image mmwise  ( 2011-09-09 15:46:26 -0500 )edit
Would I just install the desktop one with " sudo service apt-get ros-diamondback-turtlebot-desktop "?
ParkerGibbons gravatar image ParkerGibbons  ( 2011-09-09 17:45:14 -0500 )edit
Woo! It's working now with the -X command. Thank you so much!
ParkerGibbons gravatar image ParkerGibbons  ( 2011-09-09 17:51:57 -0500 )edit
to install your ROS on your ubuntu workstation follow the instructions here: http://www.ros.org/wiki/Robots/TurtleBot/diamondback/SDK%20Setup/Ubuntu%20Deb
mmwise gravatar image mmwise  ( 2011-09-10 13:33:53 -0500 )edit
1
You can get better performance in X forwarding by also enabling compression with -C, e.g.: `ssh -XC turtlebot`.
Brian Gerkey gravatar image Brian Gerkey  ( 2011-09-12 16:30:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-06 15:54:43 -0500

Seen: 742 times

Last updated: Sep 06 '11