ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Inappropriate ioctl for device

asked 2014-01-31 01:42:18 -0500

Alpha gravatar image

updated 2014-01-31 07:21:53 -0500


I have an issue running the gazebo server. It always crashes with a segfault.

Here is the debug log:

This is how I launch gazebo:

  <include file="$(find gazebo_ros)/launch/empty_world.launch">
    <arg name="debug" value="true">

I've looked around, more users seem to have this problem but there does not appear to be a definitive solution.

I run Ubuntu 12.04 with nvidia drivers (GT650M) installed by bumblebee. OpenGL appears to work (glxgears) and rviz works fine.

Any ideas?

Edit: this was using gazebo 1.9.3 and ROS Hydro

edit retag flag offensive close merge delete


Which version of gazebo are you using? Have you tried with the latest version compiled from source?

bchr gravatar image bchr  ( 2014-01-31 02:25:41 -0500 )edit

Thanks for the advice, I'll try the latest version of Gazebo (currently the default that comes with hydro) and post the result here.

Alpha gravatar image Alpha  ( 2014-01-31 06:02:57 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-01-31 07:21:15 -0500

Alpha gravatar image

Well I figured out what caused it. The urdf file was using a hokuyo laser, which in turns uses the GPU to do calculations. Disabling the GPU usage fixed the segfault.

Disable it by changing

<sensor name="laser_scanner_sensor" type="gpu_ray">


<plugin filename="" name="gazebo_ros_head_hokuyo_controller">


<sensor name="laser_scanner_sensor" type="ray">


<plugin filename="" name="gazebo_ros_head_hokuyo_controller"></plugin></sensor></plugin></sensor>
edit flag offensive delete link more

answered 2014-01-31 04:14:03 -0500

updated 2014-01-31 04:15:30 -0500

I'm guessing this is less of a problem with gazebo, and more of a problem with running gdb from roslaunch. Here is an question that produces the same errors you are seeing, and here is a bug report that I filed with ros_comm about this same issues.

I'm guessing if you set debug to false the ioctl error will disappear. If you are still seeing segfaults, something unrelated to this error is causing the problem.

edit flag offensive delete link more


Well the ioctl error will disappear (unknown if it is occuring or not, but it is not displayed) but the segfault remains. I was under the impression that the ioctl error and the segfault were related, but perhaps they are not. How else could I determine the cause of the segfault?

Alpha gravatar image Alpha  ( 2014-01-31 06:01:47 -0500 )edit

Question Tools

1 follower


Asked: 2014-01-31 01:42:18 -0500

Seen: 1,844 times

Last updated: Jan 31 '14