Ask Your Question
0

ros kinect rosrun openni_tracker openni_tracker [closed]

asked 2011-11-13 20:35:19 -0500

acp gravatar image

updated 2012-02-27 13:30:36 -0500

kwc gravatar image

when I run

rosrun openni_tracker openni_tracker

I get the following error

Failed to contact master at [localhost:11311]. Retrying...

Any clue?

Regards,

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-02-29 14:11:49

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-11-13 20:50:28 -0500

karthik gravatar image

Hi, Pls run the rosmaster with the following command in a separate terminal.

roscore

And then try your

rosrun openni_tracker openni_tracker

I suggest you to go through the tutorials. http://www.ros.org/wiki/ROS/Tutorials

Hope this helps.

Thanks, Karthik

edit flag offensive delete link more

Comments

Hi I have done that, first I run roscore in a terminal then I run rosrun openni_tracker openni_tracker in different terminal, but nothing happens, it just hangs
acp gravatar imageacp ( 2011-11-13 21:04:53 -0500 )edit
Ok are you able to run rosrun openni_camera openni_node? Are you having the problem only with this node. Check the other packages like turtlesim, gazebo.
karthik gravatar imagekarthik ( 2011-11-14 01:56:09 -0500 )edit
well, I can run rosrun turtlesim turtlesim_node,......., rosrun rviz rviz,.......,rosrun image_view disparity_view image:=/camera/depth/disparity,.......,rosrun image_view image_view image:=/camera/rgb/image_color,...., however I can not run rosrun openni_tracker openni_tracker,.....,if I want to run the point cloud node, it must be like this rosrun image_view image_view image:=/camera/depth/points,,,,,right?
acp gravatar imageacp ( 2011-11-14 21:39:03 -0500 )edit
it seems your ROS installation is fine. But the openni_tracker has the problem. When you say nothing happens, is it with the above mentioned error or you see blank terminal with no msgs after you type the run command.?
karthik gravatar imagekarthik ( 2011-11-14 22:26:52 -0500 )edit
Try checking the rostopic list and see if something is publishing. You can also check this with rxgraph.
karthik gravatar imagekarthik ( 2011-11-14 22:27:56 -0500 )edit
Well, when I run rosrun openni_tracker openni_tracker,, I get a blank terminal,,, then in a new terminal I run rxgraph and I get /openni_tracker->/rosout->/rosout
acp gravatar imageacp ( 2011-11-17 17:47:21 -0500 )edit
and in the info I get Node [/openni_tracker] Publications: * /rosout [rosgraph_msgs/Log] Subscriptions: None Services: * /openni_tracker/get_loggers * /openni_tracker/set_logger_level Pid: 1887 Connections: * topic: /rosout * to: /rosout * direction: outbound * transport: TCPROS
acp gravatar imageacp ( 2011-11-17 17:47:46 -0500 )edit

Question Tools

Stats

Asked: 2011-11-13 20:35:19 -0500

Seen: 1,002 times

Last updated: Nov 13 '11