Ask Your Question
0

Openni_tracker giving an error message "InitFromXml failed"?

asked 2016-07-18 10:54:01 -0600

anilmullapudi gravatar image

I am using ros indigo and kinect xbox.
When i run the "rosrun openni_tracker openni_tracker", i was getting error InitFromXml failed: Can't create any node of the requested type!
I followed the suggestion provided from this link1 and link2

Here is the sequence of commands that i followed. I have installed sudo apt-get install ros-indigo-freenect-stack and NITE-Bin-Dev-Linux-x64-v1.5.2.23

roslaunch freenect_launch freenect.launch &
roslaunch pr2_LookAround_pkg face_detector.rgbd.launch &
rosrun rviz rviz

I tried by adding license sudo niLicense -l 0KOIk2JeIBYClPWVnMoRKn5cdY4= , but no luck.

edit retag flag offensive close merge delete

Comments

hey buddy!!!! did u got u any help with openni_tracker and ros indigo???

Arpitsoni gravatar imageArpitsoni ( 2017-01-09 23:50:21 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-11-09 04:56:59 -0600

you can try this:sudo apt-get install libopenni-dev libopenni-sensor-primesense-dev. if it do not work : $dpkg -l|grep openni
$rosdep install –from-path -s –reinstall
$env|grep ros

Do not forget to try the other usb port !

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-18 10:54:01 -0600

Seen: 314 times

Last updated: Nov 09 '16