package install problem with electric and natty [closed]

asked 2011-10-08 06:37:15 -0600

walt gravatar image

updated 2011-10-08 08:26:06 -0600

Hello,

I'm trying to setup ros-electric-openni-kinect, which depends on openni-dev and ps-engine. I'm working on a project using ROS and the kinect, and have a pretty fresh install of natty running with all packages up to date.

I'm trying to work through the problem listed below, and figure out if it has been solved yet:

Unpacking openni-dev (from .../openni-dev_1.1.0.41~natty_i386.deb) ...
Setting up openni-dev (1.1.0.41~natty) ...
Failed: Failed to write to the file!
dpkg: error processing openni-dev (--configure):
 subprocess installed post-installation script returned error exit status 255
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 openni-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up openni-dev (1.1.0.41~natty) ...
Failed: Failed to write to the file!
dpkg: error processing openni-dev (--configure):
 subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
 openni-dev

After researching this problem in google groups I see another person with a similar problem that says:

"the install scripts in the current version tries to register modules in /var/lib/ni/modules.xml. However it doesn't create the /var/lib/ni/ directory beforehand, which causes niReg to fail and therefore also the ./install script. Creating /var/lib/ni/ before the installation worked for me."

Unfortunately, creating the /var/lib/ni directory and reinstalling isn't working for me...

Not sure if this is a recent error with the package introduced in the latest version or if there is some configuration or other problem that people (like me) are running into.

Similar issue when trying to reinstall nite-dev using Synaptic Package Manager

Setting up openni-dev (1.1.0.41~natty) ...
Failed: Failed to write to the file!
dpkg: error processing openni-dev (--configure):
 subprocess installed post-installation script returned error exit status 255
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of nite-dev:
 nite-dev depends on openni-dev (>= 1.1.0.41~natty); however:
  Package openni-dev is not configured yet.
dpkg: error processing nite-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ps-engine:
 ps-engine depends on openni-dev (>= 1.1.0.41~natty); however:
  Package openni-dev is not configured yet.
dpkg: error processing ps-engine (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ros-electric-openni-kinect:
 ros-electric-openni-kinect depends on ps-engine; however:
  Package ps-engine is not configured yet.
 ros-electric-openni-kinect depends on nite-dev; however:
  Package nite-dev is not configured yet.
 ros-electric-openni-kinect depends on openni-dev; however:
  Package openni-dev is not configured yet.
dpkg: error processing ros-electric-openni-kinect (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 openni-dev
 nite-dev
 ps-engine
 ros-electric-openni-kinect
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up openni-dev (1.1.0.41~natty ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-05-09 22:25:21