Ask Your Question
1

Package dependency problem while installing ROS in Ubuntu Natty (11.04)

asked 2011-06-01 13:18:28 -0500

tbocs gravatar image

updated 2011-06-17 11:20:20 -0500

Vincent Rabaud gravatar image

I just saw the public Debian distribution of ROS for Ubuntu Natty, which I have been waiting for for a long time. However, I cannot install ros-diamondback-ros-comm, because it requires a package called "libkrb5-dev", which requires "krb5-multidev", which has the following dependency errors that cannot be resolved:

krb5-multidev:

Depends: libkrb5-3 (=1.8.3+dfsg-5ubuntu2) but 1.8.3+dfsg-5ubuntu2.1 is to be installed

Depends: libk5crypto3 (=1.8.3+dfsg-5ubuntu2) but 1.8.3+dfsg-5ubuntu2.1 is to be installed

Depends: libgssapi-krb5-2 (=1.8.3+dfsg-5ubuntu2) but 1.8.3+dfsg-5ubuntu2.1 is to be installed

I have noticed that these three packages are pre-installed as "version 1.8.3+dfsg-5ubuntu2.1" by Ubuntu (11.04 amd64). I tried the force version, but it caused system error and made me reinstall the whole system. Is anyone encountering similar issue? I appreciate any suggestions that help me solve this dependency problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-06-17 11:26:42 -0500

Vincent Rabaud gravatar image

There are the only direct dependencies of ros-comm on natty. This sounds like there is something else going on with your Natty installation (maybe you are using an external ppa or something):

libc6, build-essential, cmake, python-yaml, subversion, python-numpy, python-imaging, python-paramiko, libapr1-dev, libaprutil1-dev, liblog4cxx10-dev, libbz2-dev, pkg-config
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-01 13:18:28 -0500

Seen: 358 times

Last updated: Jun 17 '11