Ask Your Question
0

unable to locate package ros-electric-nxtall

asked 2020-04-20 22:22:51 -0600

tinjiang gravatar image

Hi everyone! I tried to install the nxt ros package on ubuntu 11.10 and 11.04.

I followed the instructions on the ros wiki installation page, however, everytime I tried, I end up getting the "unable to locate package" message.

I know that the ubuntu natty and onieric are old versions and are unsupported anymore, so I have already changed my sources.list file with the command below before running the installation instructions:

sudo sed -i -re 's/([a-z]{2}\.)?archive.ubuntu.com|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

and then I went to the Ros index page to search for the nxt and I couldn't find any package that contains "nxt" in its name. Is this the reason that the apt-get is unable to locate the package? Can anybody tell me what steps did I do wrong or is this the server side problem and how can I fix it? Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-21 04:31:41 -0600

gvdhoorn gravatar image

First: the packages you refer to are very old. ROS Electric is from 2011.

This means the packages you are referring to cannot be installed on newer versions of ROS (or at least: not with apt).

As you have installed Ubuntu 11, you should be able to still install them, but you will have to use the Snapshot repository.

Refer to #q340464 for a related question (although the OP there asks about ROS Fuerte) and a link to the page which explains how to configure the required repositories.

Finally: you are probably already aware, but please note that both Ubuntu 11.x and ROS Electric are very old, unsupported and unmaintained.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-04-20 21:46:48 -0600

Seen: 65 times

Last updated: Apr 21 '20